Bug 455102 - Banshee corrupts the iPod database on write.
Banshee corrupts the iPod database on write.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ipod-sharp (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-11 18:51 EDT by Sævaldur Arnar Gunnarsson
Modified: 2009-01-16 18:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 18:40:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sævaldur Arnar Gunnarsson 2008-07-11 18:51:35 EDT
Description of problem:
Banshee seems to corrupt the iPod song database every time I add songs to the
iPod though Banshee.

Version-Release number of selected component (if applicable):
banshee-1.0.0-1.fc9.i386
podsleuth-0.6.0-6.fc9.i386
libgpod-0.6.0-4.fc9
gtkpod-0.99.12-2.fc9.i386
rhythmbox-0.11.5-13.fc9.i386


How reproducible:
Always.

Steps to Reproduce:
1. Launch Banshee
2. Drag some songs from the music library to the iPod
3. Eject the iPod
  
Actual results:
The iPod reports that there are no songs on it.

Expected results:
I should see both the songs that were already on the iPod as well as the new
songs I copied from Banshee.

Additional info:
The iPod is a black Classic 80GB
Model: xB147 (according to gtkpod)

I can still play songs from the iPod through Banshee, but not if I disconnect
the iPod and try to play some music on the iPod itself.

I can however fix the song database with two different methods.

1) I can use gtkpod; Load the iPod, click "Save Changes" and exit the application.

2) I can also use rhythmbox; Drag some songs from the music library to the iPod
and eject it.
Comment 1 Nigel Jones 2008-08-14 09:16:35 EDT
This package has now been orphaned, hopefully someone will be able to pick it up and resolve the reported bug soon.
Comment 2 David Nielsen 2008-10-11 05:38:48 EDT
Can you reproduce with Banshee 1.2.1 as is present in Fedora 9 now?
Comment 3 Sævaldur Arnar Gunnarsson 2008-10-21 08:19:20 EDT
Yes, this problem is still reproducable on Banshee 1.2.1

[addi@addi ~]$ rpm -q banshee
banshee-1.2.1-2.fc9.i386
Comment 4 David Nielsen 2008-10-21 09:10:58 EDT
I have pushed your bug upstream here:

http://bugzilla.gnome.org/show_bug.cgi?id=557238

However due to some problem with upstreams bugtracker I have been unable to put your email as CC for the report.

Please follow up on the new bug report, your Fedora Banshee maintainer should suck in eventual bugfixes as they become available in new releases. Thank you for your report.
Comment 5 Michel Alexandre Salim 2009-01-01 18:28:29 EST
Reporter noted that Fedora 10's banshee-1.4.1 no longer exhibits this, so it's probably due to ipod-sharp 0.8.0.

ipod-sharp is being bumped to 0.8.1 for Fedora 9 as well; will update Banshee as soon as that lands.
Comment 6 Fedora Update System 2009-01-07 04:09:38 EST
ipod-sharp-0.8.1-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update ipod-sharp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-0031
Comment 7 Fedora Update System 2009-01-16 18:40:45 EST
ipod-sharp-0.8.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.