Bug 455103 - (CUPS-prints-PS-codes) Some Windows XP SP3 clients are sending PostScript files to the server that are not identified as PostScript and then printed as text
Some Windows XP SP3 clients are sending PostScript files to the server that a...
Status: CLOSED DUPLICATE of bug 430067
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-11 18:57 EDT by Aram Agajanian
Modified: 2008-07-15 05:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 05:16:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aram Agajanian 2008-07-11 18:57:29 EDT
Description of problem:
I recently set up some Windows XP computers to print to my CUPS server via IPP.
 (IPP support has changed with XP SP3, so I had to change the XP printer
configuration.)  

CUPS is apparently identifying PostScript documents using logic in
/etc/cups/mime.types.  Specifically for these documents, it is using the
following line:

                               (contains(0,1024,"LANGUAGE=POSTSCRIPT") \

However, some PostScript files being generated by XP SP3 has the string
"LANGUAGE=POSTSCRIPT" starting past character 1024.  (One PostScript file that I
printed had the "LANGUAGE=POSTSCRIPT" string start at charactor 1050.)  So,
these print jobs are not identified as PostScript files.  The printer prints
them out as text files, instead.

In order to get CUPS to detect these files as PostScript files, I changed the
line above to:

                               (contains(0,2048,"LANGUAGE=POSTSCRIPT") \


Version-Release number of selected component (if applicable):
cups-1.2.4-11.18.el5_2.1

How reproducible:
Not all print jobs from the Windows XP clients exhibit this problem.  However,
when printing out certain web pages or documents, the problem occurs every time.

Steps to Reproduce:
1. Print document which happens to generate a PostScript file where the
"LANGUAGE=POSTSCRIPT" text comes after character 1024.
  
Actual results:
Printer prints out a lot of PostScript codes.

Expected results:
Printer interprets PostScript code and prints out a document which may contain
formatting and graphics.

Additional info:
Comment 1 Tim Waugh 2008-07-15 05:16:43 EDT

*** This bug has been marked as a duplicate of 430067 ***

Note You need to log in before you can comment on or make changes to this bug.