Bug 455189 - Automake macros should be installed into %{_datadir}/aclocal
Automake macros should be installed into %{_datadir}/aclocal
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: apr (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 455002
  Show dependency treegraph
 
Reported: 2008-07-13 15:34 EDT by Jochen Schmitt
Modified: 2008-07-15 18:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 18:32:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suggested SPEC file to fix the reported bug (13.13 KB, text/plain)
2008-07-13 15:45 EDT, Jochen Schmitt
no flags Details

  None (edit)
Description Jochen Schmitt 2008-07-13 15:34:28 EDT
The files build/apr*.m4 should be installed in &{_datadir}/aclocal
Comment 1 Jochen Schmitt 2008-07-13 15:35:51 EDT
Sorry, I think all *.m4 files should be installed into %{_datadir}/aclocal
Comment 2 Jochen Schmitt 2008-07-13 15:45:55 EDT
Created attachment 311667 [details]
Suggested SPEC file to fix the reported bug

Here a SPEC file which should fix the reported bug.
Comment 3 Bojan Smojver 2008-07-13 17:16:21 EDT
Not applicable. These are internal files used to build APR.
Comment 4 Jochen Schmitt 2008-07-14 10:14:06 EDT
Unfortunately, I have to inform you, that the configure.ac file of subcommander 
will refer on it, so it neccessary to include this files to %{_datadir}/aclocal
Comment 5 Bojan Smojver 2008-07-14 17:59:49 EDT
I have no idea what you're talking about. Could you please explain why these m4
files need to be installed, given they are used only by the build itself?

Joe, could you please comment on this?
Comment 6 Joe Orton 2008-07-15 04:08:56 EDT
The find_ap[ru].m4 files from apr and apr-util are intended for use by
third-party projects so could reasonably be included in datadir/aclocal; nothing
else needs to be nor should be.
Comment 7 Jochen Schmitt 2008-07-15 09:49:21 EDT
OK, thats sounds good, so let do it in the way you explain it.
Comment 8 Bojan Smojver 2008-07-15 18:32:52 EDT
Fixed in apr-1.3.2-2.fc10 and apr-util-1.3.2-7.fc10.

Note You need to log in before you can comment on or make changes to this bug.