Bug 455335 - yum update rpm fails due to dependencies
yum update rpm fails due to dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-14 16:46 EDT by Quentin Armitage
Modified: 2008-07-14 16:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-14 16:56:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quentin Armitage 2008-07-14 16:46:11 EDT
Description of problem:
yum update rpm rpm-build rpm-libs rpm-python rpm-devel
fails with dependency errors

Version-Release number of selected component (if applicable):
Installed version of rpm: 
Version attempting update to: 

How reproducible:
Always

Steps to Reproduce:
1.yum update rpm rpm-build rpm-libs rpm-python rpm-devel
2.
3.
  
Actual results:
Update fails

Expected results:
Update succeeds

Additional info:
Output of yum update ...:
[root@samson hsn]# yum update rpm-build rpm rpm-devel rpm-libs rpm-python
Loaded plugins: dellsysidplugin, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package rpm-libs.i386 0:4.5.90-0.git8426.6 set to be updated
---> Package rpm-devel.i386 0:4.5.90-0.git8426.6 set to be updated
---> Package rpm.i386 0:4.5.90-0.git8426.6 set to be updated
--> Processing Dependency: librpm-4.4.so for package: net-snmp
--> Processing Dependency: librpm-4.4.so for package: gdb
--> Processing Dependency: librpm-4.4.so for package: net-snmp-libs
--> Processing Dependency: librpmdb-4.4.so for package: gdb
--> Processing Dependency: librpmio-4.4.so for package: net-snmp
--> Processing Dependency: librpmio-4.4.so for package: net-snmp-libs
---> Package rpm-build.i386 0:4.5.90-0.git8426.6 set to be updated
--> Processing Dependency: lzma for package: rpm-build
--> Processing Dependency: perl(Module::ScanDeps::DataFeed) for package: rpm-build
---> Package rpm-python.i386 0:4.5.90-0.git8426.6 set to be updated
--> Running transaction check
--> Processing Dependency: librpm-4.4.so for package: net-snmp
--> Processing Dependency: librpm-4.4.so for package: gdb
--> Processing Dependency: librpm-4.4.so for package: net-snmp-libs
--> Processing Dependency: librpmdb-4.4.so for package: gdb
--> Processing Dependency: librpmio-4.4.so for package: net-snmp
--> Processing Dependency: librpmio-4.4.so for package: net-snmp-libs
---> Package lzma.i386 0:4.32.5-1.fc9 set to be updated
--> Processing Dependency: lzma-libs = 4.32.5-1.fc9 for package: lzma
--> Processing Dependency: liblzmadec.so.0 for package: lzma
---> Package perl-Module-ScanDeps.noarch 0:0.84-1.fc10 set to be updated
--> Processing Dependency: perl(Module::Build::ModuleInfo) for package:
perl-Module-ScanDeps
--> Running transaction check
--> Processing Dependency: librpm-4.4.so for package: net-snmp
--> Processing Dependency: librpm-4.4.so for package: gdb
--> Processing Dependency: librpm-4.4.so for package: net-snmp-libs
--> Processing Dependency: librpmdb-4.4.so for package: gdb
--> Processing Dependency: librpmio-4.4.so for package: net-snmp
--> Processing Dependency: librpmio-4.4.so for package: net-snmp-libs
---> Package perl-Module-Build.i386 1:0.2808-36.fc10 set to be updated
--> Processing Dependency: perl(ExtUtils::CBuilder) >= 0.15 for package:
perl-Module-Build
---> Package lzma-libs.i386 0:4.32.5-1.fc9 set to be updated
--> Running transaction check
---> Package perl-ExtUtils-CBuilder.i386 1:0.21-36.fc10 set to be updated
--> Processing Dependency: librpm-4.4.so for package: net-snmp
--> Processing Dependency: librpm-4.4.so for package: gdb
--> Processing Dependency: librpm-4.4.so for package: net-snmp-libs
--> Processing Dependency: librpmdb-4.4.so for package: gdb
--> Processing Dependency: librpmio-4.4.so for package: net-snmp
--> Processing Dependency: librpmio-4.4.so for package: net-snmp-libs
--> Finished Dependency Resolution
1:net-snmp-libs-5.4.1-19.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: librpm-4.4.so is needed by package
1:net-snmp-libs-5.4.1-19.fc10.i386 (installed)
1:net-snmp-libs-5.4.1-19.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: librpmio-4.4.so is needed by package
1:net-snmp-libs-5.4.1-19.fc10.i386 (installed)
1:net-snmp-5.4.1-19.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: librpm-4.4.so is needed by package
1:net-snmp-5.4.1-19.fc10.i386 (installed)
gdb-6.8-15.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: librpmdb-4.4.so is needed by package
gdb-6.8-15.fc10.i386 (installed)
1:net-snmp-5.4.1-19.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: librpmio-4.4.so is needed by package
1:net-snmp-5.4.1-19.fc10.i386 (installed)
gdb-6.8-15.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: librpm-4.4.so is needed by package
gdb-6.8-15.fc10.i386 (installed)
Error: Missing Dependency: librpmdb-4.4.so is needed by package
gdb-6.8-15.fc10.i386 (installed)
Error: Missing Dependency: librpmio-4.4.so is needed by package
1:net-snmp-5.4.1-19.fc10.i386 (installed)
Error: Missing Dependency: librpm-4.4.so is needed by package
1:net-snmp-5.4.1-19.fc10.i386 (installed)
Error: Missing Dependency: librpm-4.4.so is needed by package
gdb-6.8-15.fc10.i386 (installed)
Error: Missing Dependency: librpmio-4.4.so is needed by package
1:net-snmp-libs-5.4.1-19.fc10.i386 (installed)
Error: Missing Dependency: librpm-4.4.so is needed by package
1:net-snmp-libs-5.4.1-19.fc10.i386 (installed)
[root@samson hsn]#
Comment 1 Will Woods 2008-07-14 16:56:58 EDT
gdb and net-snmp have already been rebuilt. This will be fixed in tomorrow's
rawhide.

Note You need to log in before you can comment on or make changes to this bug.