This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 455375 - atop causes logrotate to generate errors
atop causes logrotate to generate errors
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: atop (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Kairo Araujo
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-15 04:25 EDT by Ulrik Mikaelsson
Modified: 2008-08-03 16:16 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.23-8.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 03:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrik Mikaelsson 2008-07-15 04:25:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071222 Firefox/3.0.1

Description of problem:
The current Fedora EPEL atop RPM 

Version-Release number of selected component (if applicable):
atop-1.23-7.el5

How reproducible:
Always


Steps to Reproduce:
Run logrotate manually:
/etc/cron.daily/logrotate

Actual Results:
[ulrik@bigNfat atop]$ sudo /etc/cron.daily/logrotate 
error: atop:prerotate or postrotate without endscript
[ulrik@bigNfat atop]$ 


Expected Results:
[ulrik@bigNfat atop]$ sudo /etc/cron.daily/logrotate 
[ulrik@bigNfat atop]$ 


Additional info:
The problem is the last line in atop.logrotate:
    create 0600 root root
    postrotate   <<<< NOT VALID
}

Instead, something like the Ubuntu atop.logrotate should be used:
/var/log/atop.log {
    rotate 14
    daily
    nocompress
    nocreate
    missingok
    prerotate
        if pidof atop 2>&1 > /dev/null; then
            invoke-rc.d --quiet atop stop 2>&1 > /dev/null
        fi
    endscript
    postrotate
        invoke-rc.d --quiet atop start 2>&1 > /dev/null
    endscript
}
Comment 1 Fedora Update System 2008-07-21 19:25:08 EDT
atop-1.23-8.fc8 has been submitted as an update for Fedora 8
Comment 2 Fedora Update System 2008-07-21 19:26:21 EDT
atop-1.23-8.fc9 has been submitted as an update for Fedora 9
Comment 4 Kairo Araujo 2008-07-21 20:31:48 EDT
Fixed in 1.23-8
Comment 5 Fedora Update System 2008-07-23 03:15:28 EDT
atop-1.23-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Ulrik Mikaelsson 2008-08-03 16:16:04 EDT
Proposed EPEL updates seems to work.

Note You need to log in before you can comment on or make changes to this bug.