Bug 455470 - System Drops to shell after software update.
System Drops to shell after software update.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
9
alpha Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-15 13:26 EDT by Martin Long
Modified: 2013-01-09 23:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 16:31:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Long 2008-07-15 13:26:10 EDT
Description of problem: 
System Drops to shell after software update.


Version-Release number of selected component (if applicable):


How reproducible: Every time, on 3 different memory sticks on 7 different 
computers.


Steps to Reproduce:
1.Build a Live USB using either Windows or linux
2.Boot on Live USB while connected to the network and approve updates
3.restart system
  
Actual results:
/init: line478: /sysroot/etc/udev/rules.d/50-udev*: ambiguous redirect Bug in 
initramfs /init detected. dropping to a shell Good Luck


Expected results: Normal boot


Additional info: There are two files in the rules.d directory that start 
with "50-udev"  I renamed the one ending in "rpmsave" to "50-ud" so it 
wouldn't be picked up by "50-udev*" the system would then boot.
Comment 1 Jeremy Katz 2008-07-15 18:01:09 EDT
How large of an overlay did you create?
Comment 2 Martin Long 2008-07-15 18:21:20 EDT
I first tried to create a 5000 MB overlay but received an error stating that 
my maximum was 2048.  I tried specifying an overlay of 2048 and saw the same 
error.  So I specified an overlay of 2024 MB which worked.  I'm using a 16Gig 
stick.
Comment 3 Jeremy Katz 2008-07-16 16:31:31 EDT
Ahh, I see what it is.  This is a bug that will manifest with an updated udev
package (only).  I've fixed it up in mkliveinitrd so that future images won't
have the problem.  

Note You need to log in before you can comment on or make changes to this bug.