Bug 455656 - First permanent changes to system are in partitioning, not package installation
First permanent changes to system are in partitioning, not package installation
Status: CLOSED NEXTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
All Linux
low Severity low
: ---
: ---
Assigned To: Paul W. Frields
Paul W. Frields
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-16 16:13 EDT by Andy Lindeberg
Modified: 2008-11-23 13:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-23 13:21:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Lindeberg 2008-07-16 16:13:21 EDT
On the first page of Chapter 4, there is a note at the top that says:

"To abort the installation process at any time before the Installing Packages
screen, either press Ctrl+Alt+Del or power off the computer with the power
switch. Fedora makes no changes to your computer until package installation begins."

This isn't true, as partitioning makes permanent changes to the computer and
occurs before package selection. It should probably read something like:

"To abort the installation, either press Ctrl+Alt+Del or power off your computer
with the power switch. You may abort the installation process without
consequence at any time prior to partitioning, as Fedora makes no permanent
changes to your system until that point. Please be aware that stopping the
installation after partitioning has begun can leave your system unusable."

Link to page:
http://docs.fedoraproject.org/install-guide/f9/en_US/ch-beginninginstallation.html
Comment 1 David Nalley 2008-11-21 11:39:06 EST
Added the following: 

To abort the installation, either press <keycombo><keycap>Ctrl
      </keycap><keycap>Alt</keycap><keycap>Del</keycap></keycombo>
      or power off your computer with the power switch. You may
      abort the installation process without consequence at any time
      prior to selecting <guibutton>Write changes to disk</guibutton>
      on the <guilabel>Write partitioning to disk</guilabel> screen,
      as Fedora makes no permanent changes to your computer until
      that point. Please be aware that stopping the installation
      after partitioning has begun can leave your computer unusable.

Did this in local commit 322bbcb
Committed this change
Comment 2 Paul W. Frields 2008-11-21 13:36:00 EST
Word of style guidance:  Sentence length.  That second sentence should be split into two, because we try to hold to 25 words or less whenever possible.  Suggestion:

'''
You may abort the installation process without consequence at any time prior to selecting <guibutton>Write changes to disk</guibutton> on the <guilabel>Write partitioning to disk</guilabel> screen.  Fedora makes no permanent changes to your computer until that point.
'''
Comment 3 David Nalley 2008-11-21 14:10:47 EST
Fixed in commit 28291dd
Comment 4 David Nalley 2008-11-23 13:21:09 EST
Closing this ticket since 322bbcb and 28291dd address this issue.

Note You need to log in before you can comment on or make changes to this bug.