Bug 455660 - RHEL Installation on multipath LUNs with Single controller fails
RHEL Installation on multipath LUNs with Single controller fails
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.1
i386 Linux
low Severity high
: rc
: ---
Assigned To: Ales Kozumplik
:
Depends On:
Blocks: 726828
  Show dependency treegraph
 
Reported: 2008-07-16 16:43 EDT by Pradipmaya Maharana
Modified: 2014-09-30 19:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-23 14:25:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradipmaya Maharana 2008-07-16 16:43:56 EDT
Description of problem:
Installing OS with 2 controllers, with option "linux mpath", would install the 
OS on the mpath device, so the /root device is configured on multipath devices.
But the same, if tried with installing the OS with only one controller and then 
adding the second controller later after installation, would not let the /root 
be configured under multipath device.

Version-Release number of selected component (if applicable):
RHEL 5.1 (32 bit and 64 bit)

How reproducible:
With Dual Controllers present :  
- Install RHEL 5.1 with option “linux mpath” 
- Partition manager shows you the devices as /dev/mpath0  
- Proceed with installation and complete it. Installation goes fine. 
- Once rebooted successfully, run “multipath –ll”; we can see that the /root 
device (which lies on mpath0) is configured under multipath 
 
[root@localhost ~]# multipath -ll 
mpath1 (22298000155714d81) dm-5 Intel,Multi-Flex 
[size=5.0G][features=1 queue_if_no_path][hwhandler=1 intel] 
\_ round-robin 0 [prio=50][active] 
 \_ 0:0:0:1 sdb 8:16  [active][ready] 
\_ round-robin 0 [prio=1][enabled] 
 \_ 0:0:3:1 sdd 8:48  [active][ready] 
mpath0 (2220400015593d28b) dm-0 Intel,Multi-Flex 
[size=20G][features=1 queue_if_no_path][hwhandler=1 intel] 
\_ round-robin 0 [prio=50][active] 
 \_ 0:0:0:0 sda 8:0   [active][ready] 
\_ round-robin 0 [prio=1][enabled] 
 \_ 0:0:3:0 sdc 8:32  [active][ready] 
- My OS is on dm-0, which is 20G 
- The reason why /root could be configured under multipath in the above step is 
because the option at installation “linux mpath” add multipath modules in the 
boot image, so before the OS could be loaded, multipath modules are already 
loaded. 
- Hence the /root can be loaded on the  
 
 
With Single controller: 
- Install RHEL 5.1 with option “linux mpath” 
- Partition manager shows you the devices as /dev/sda, as there is one 
device/path per LUN. 
- Proceed with installation and complete it. Installation goes fine. 
- Once rebooted, add the second controller in and reboot (just make sure the 
devices are rescanned properly) 
- Once rebooted successfully, run “multipath –ll”; we can see that the /root 
device (which lies on mpath0) is NOT configured under multipath. 
[root@localhost ~]# multipath -ll 
mpath0 (22298000155714d81) dm-0 Intel,Multi-Flex 
[size=5.0G][features=1 queue_if_no_path][hwhandler=1 intel] 
\_ round-robin 0 [prio=50][active] 
 \_ 0:0:0:1 sdb 8:16  [active][ready] 
\_ round-robin 0 [prio=1][enabled] 
 \_ 0:0:1:1 sdd 8:48  [active][ready] 
 
- I can see only one LUN configured under multipath, which does not have any OS 
component (/root, /boot, swap) 
- So the problem here is as the multipath modules are not part of the boot 
image and are not set in the right sequence to load, /root loads first and 
multipath loads later. 
- Now that the /root device is already loaded it can’t configured under 
multipath. 
- The solution probably is to make a new initrd image with dm-multipath module. 
- We tried that but still the /root device won’t get configured under 
multipath. 


Steps to Reproduce:
1. Mentioned above.
  
Actual results:
/root can not be configured on multipath devices with initially installed the 
OS with single controller.

Expected results:
Os should allow /root to be configured under multipath

Additional info:
Comment 1 Steven J. Levine 2008-07-22 12:01:17 EDT
Reassigning -- this doesn't appear to be a documentation issue.
Comment 2 Ben Marzinski 2008-08-13 12:58:03 EDT
This seems to be an anaconda issue, not a multipath issue.
Comment 3 Jim Lester 2008-09-05 10:43:38 EDT
Behavior should be changed to force multipath install when mpath option is present, regardless of the number of LUNs present at time of install. 

Alternate case of this:
Single fibre channel HBA with software iSCSI failover. This configuration is a cost effective way to provide some redundancy to the system. Obviously the iSCSI can not be present at time of install. 

If the user specifies mpath, it should install multipathed.
Comment 4 Chris Lumens 2008-09-26 16:48:39 EDT
What's the exact error message you are seeing here?
Comment 5 Jim Lester 2008-12-10 14:14:42 EST
There is no error message that is displayed during install at least to the graphical screen. 

The problem just seems to be that if the installer is presented with only one path to disk, it disregards the "linux mpath" directive given at the install prompt.

When you get to the screen where you can select the disk to install to, if there are two paths to storage you see "/dev/mapper/mpath0" in the devices list. If there was only one path to disk, you see "/dev/sda". 

There must be a check somewhere that it looks to see if there are two paths to the same disk and if not, it exits out of the multipath logic. 

The long and the short of it is, that if mpath is passed to the installed, then it should do a multipath install regardless of how many paths are active.
Comment 6 Rich Graves 2009-05-29 22:03:04 EDT
(Vouch for use case in comment #3)

For now I'm keeping an "extra" multiport FC HBA just for installs.
Comment 7 Felipe Pereira 2011-04-05 15:17:25 EDT
I confirm this error in the RHEL 5.6 installer. Seems this bug was not fixed yet.

Our case is: host has more than one FC port but currently has only one connection to the storage. Eventually we'll connect more ports and we want to install RHEL multipathed.
Comment 8 Felipe Pereira 2011-04-05 15:30:43 EDT
I think this KB article is related.
https://access.redhat.com/kb/docs/DOC-52982
Comment 11 RHEL Product and Program Management 2011-08-23 14:25:22 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.