Bug 455673 - PXE kickstart install still attempts to get stage2.img from CD
PXE kickstart install still attempts to get stage2.img from CD
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-16 18:10 EDT by Orion Poplawski
Modified: 2008-07-18 11:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-18 11:42:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-07-16 18:10:20 EDT
Description of problem:

PXE kickstart install still attempts to get stage2.img from CD.  Not terrible,
but seems to slow things down unnecessarily.  Does the installer have any idea
at this point that it is a PXE boot?

Install source is http url in the kickstart file.
Comment 1 Jeremy Katz 2008-07-16 21:19:26 EDT
There's no way to tell that you've booted from pxe, unfortunately.  So we always
look for the CD.  And that looking is slow right now due to trying to work
around some changes in the kernel.  pjones was working on pushing some kernel
patches to make things better
Comment 2 Chris Lumens 2008-07-18 11:42:07 EDT
If you want to completely bypass the CD check, you'll need to add stage2=<path
to stage2.img> to your cmdline options.

Note You need to log in before you can comment on or make changes to this bug.