Bug 455676 - Missing package dialog box stays on screen in VNC
Missing package dialog box stays on screen in VNC
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-16 18:16 EDT by Orion Poplawski
Modified: 2009-04-14 17:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 17:02:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-07-16 18:16:23 EDT
Description of problem:

Using VNC to connect to install.  My kickstart file specifies several missing
packages.  Up pops a missing package dialog.  I select "continue", that box
highlights but the dialog stays on the screen making it seem like it didn't take.
Comment 1 Chris Lumens 2008-07-18 16:30:33 EDT
Can you switch to tty1 and see if there's a traceback being displayed?  This has
all the makings of the invisible tracebacks we sometimes get with UI elements.
Comment 2 Orion Poplawski 2008-07-18 17:51:58 EDT
Don't see any tracebacks.

tty1:

Xlib: extension "RANDR" missing on display ":1.0"
15:42:28 Starting graphical installation...

tty3:

15:42:06 INFO : moving (1) to step basepkgsel

Comment 3 Chris Lumens 2008-10-09 13:52:11 EDT
Still seeing this in F10 beta?
Comment 4 Orion Poplawski 2008-10-09 13:58:44 EDT
Yup.
Comment 5 Chris Lumens 2008-10-23 11:18:50 EDT
Yeah I see it happening too, but it really only stays up on the screen for an extra second or two until the next dialog appears.  Are you seeing it stay up for a really long time?  If not, I'm leaning towards closing this report.
Comment 6 Orion Poplawski 2008-10-23 11:23:18 EDT
It depends on how much more depsolving is left to do.  If there is a lot, it can stay up for a long time.  It stays up until the next dialog comes up.  It's definitely not a show stopper, but it is enough to make me think "Is this still working?" for a bit.
Comment 7 Chris Lumens 2008-10-23 11:55:00 EDT
Oh I see what's going on there.  We're deleting the dialogs but our lack of a main loop means the deletions don't really take effect on the display until we get around to processing events.  This should be fixed up in the next build of anaconda by doing more event processing calls.
Comment 8 Chris Lumens 2008-11-03 16:23:31 EST
Had to revert the fix here since it causes the Next buttons to look unresponsive and that's a much bigger UI problem.
Comment 9 Bug Zapper 2008-11-25 21:34:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Orion Poplawski 2009-04-14 17:02:05 EDT
This appears to be fixed now.

Note You need to log in before you can comment on or make changes to this bug.