Bug 455864 - a lot of unnecessary dependencies
a lot of unnecessary dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 455868 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-18 09:26 EDT by udo
Modified: 2014-01-21 18:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-18 10:08:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description udo 2008-07-18 09:26:38 EDT
Description of problem:
A lot of unnecessary i386 dependencies on x86_64 system,

Version-Release number of selected component (if applicable):
Repository?

How reproducible:
yup update (at this time)

Steps to Reproduce:
1. yum update
2. see few x86_64 components to be updated
3. say Yes and see lot of i386 stuff being unnecessarily selected;  conflict
then starts etc
  
Actual results:


Expected results:
Clean upgarde of stuff without unnecessary rpms 

Additional info:

# yum update 
Loaded plugins: merge-conf, refresh-packagekit
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package yelp.x86_64 0:2.22.1-4.fc9 set to be updated
---> Package devhelp.x86_64 0:0.19.1-3.fc9 set to be updated
--> Processing Dependency: gecko-libs = 1.9 for package: nspluginwrapper
--> Processing Dependency: gecko-libs = 1.9 for package: nspluginwrapper
---> Package xulrunner.x86_64 0:1.9.0.1-1.fc9 set to be updated
---> Package firefox.x86_64 0:3.0.1-1.fc9 set to be updated
--> Running transaction check
---> Package xulrunner.i386 0:1.9-0.60.beta5.fc9 set to be updated
--> Processing Dependency: libsmime3.so for package: xulrunner
--> Processing Dependency: libgconf-2.so.4 for package: xulrunner
--> Processing Dependency: liblcms.so.1 for package: xulrunner
--> Processing Dependency: libsqlite3.so.0 for package: xulrunner
--> Processing Dependency: libssl3.so for package: xulrunner
--> Processing Dependency: libpopt.so.0 for package: xulrunner
--> Processing Dependency: libnss3.so(NSS_3.7) for package: xulrunner
--> Processing Dependency: libbonobo-activation.so.4 for package: xulrunner
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.12) for package: xulrunner
--> Processing Dependency: libgnome-2.so.0 for package: xulrunner
--> Processing Dependency: libnss3.so(NSS_3.9) for package: xulrunner
--> Processing Dependency: libnss3.so(NSS_3.5) for package: xulrunner
--> Processing Dependency: libgnomevfs-2.so.0 for package: xulrunner
--> Processing Dependency: libbz2.so.1 for package: xulrunner
--> Processing Dependency: libnss3.so(NSS_3.6) for package: xulrunner
--> Processing Dependency: libbonobo-2.so.0 for package: xulrunner
--> Processing Dependency: libnss3.so for package: xulrunner
--> Processing Dependency: libnssutil3.so for package: xulrunner
--> Processing Dependency: libsmime3.so(NSS_3.9.3) for package: xulrunner
--> Processing Dependency: libnss3.so(NSS_3.9.3) for package: xulrunner
--> Processing Dependency: libORBit-2.so.0 for package: xulrunner
--> Processing Dependency: libnss3.so(NSS_3.11.7) for package: xulrunner
--> Processing Dependency: libnss3.so(NSS_3.12) for package: xulrunner
--> Processing Dependency: libsmime3.so(NSS_3.4) for package: xulrunner
--> Processing Dependency: libsmime3.so(NSS_3.4.1) for package: xulrunner
--> Processing Dependency: libsmime3.so(NSS_3.3) for package: xulrunner
--> Processing Dependency: libnss3.so(NSS_3.10) for package: xulrunner
--> Processing Dependency: libssl3.so(NSS_3.2) for package: xulrunner
--> Processing Dependency: libsmime3.so(NSS_3.6) for package: xulrunner
--> Processing Dependency: libhunspell.so.1 for package: xulrunner
--> Processing Dependency: libnss3.so(NSS_3.2) for package: xulrunner
--> Processing Dependency: libnss3.so(NSS_3.3) for package: xulrunner
--> Processing Dependency: libnss3.so(NSS_3.9.2) for package: xulrunner
--> Processing Dependency: libdbus-glib-1.so.2 for package: xulrunner
--> Processing Dependency: libsmime3.so(NSS_3.2) for package: xulrunner
--> Processing Dependency: libdbus-1.so.3 for package: xulrunner
--> Processing Dependency: libssl3.so(NSS_3.4) for package: xulrunner
--> Processing Dependency: libnss3.so(NSS_3.4) for package: xulrunner
--> Processing Dependency: libnss3.so(NSS_3.11.1) for package: xulrunner
--> Running transaction check
---> Package bzip2-libs.i386 0:1.0.5-2.fc9 set to be updated
---> Package gnome-vfs2.i386 0:2.22.0-1.fc9 set to be updated
--> Processing Dependency: libavahi-client.so.3 for package: gnome-vfs2
--> Processing Dependency: libxml2.so.2 for package: gnome-vfs2
--> Processing Dependency: libattr.so.1 for package: gnome-vfs2
--> Processing Dependency: libhal-storage.so.1 for package: gnome-vfs2
--> Processing Dependency: libacl.so.1 for package: gnome-vfs2
--> Processing Dependency: libavahi-glib.so.1 for package: gnome-vfs2
--> Processing Dependency: libavahi-common.so.3 for package: gnome-vfs2
--> Processing Dependency: libacl.so.1(ACL_1.0) for package: gnome-vfs2
--> Processing Dependency: libhal.so.1 for package: gnome-vfs2
---> Package hunspell.i386 0:1.2.1-7.fc9 set to be updated
--> Processing Dependency: libtinfo.so.5 for package: hunspell
--> Processing Dependency: libncursesw.so.5 for package: hunspell
---> Package sqlite.i386 0:3.5.6-2.fc9 set to be updated
--> Processing Dependency: libreadline.so.5 for package: sqlite
---> Package libgnome.i386 0:2.22.0-3.fc9 set to be updated
--> Processing Dependency: libaudiofile.so.0 for package: libgnome
--> Processing Dependency: libesd.so.0 for package: libgnome
---> Package libbonobo.i386 0:2.22.0-2.fc9 set to be updated
---> Package lcms-libs.i386 0:1.17-5.fc9 set to be updated
---> Package GConf2.i386 0:2.22.0-1.fc9 set to be updated
--> Processing Dependency: liblber-2.4.so.2 for package: GConf2
--> Processing Dependency: libldap-2.4.so.2 for package: GConf2
---> Package popt.i386 0:1.13-4.fc9 set to be updated
---> Package dbus-glib.i386 0:0.74-8.fc9 set to be updated
---> Package nss.i386 0:3.12.0.3-0.9.1.fc9 set to be updated
---> Package dbus-libs.i386 0:1.2.1-1.fc9 set to be updated
---> Package ORBit2.i386 0:2.14.12-3.fc9 set to be updated
--> Processing Dependency: libIDL-2.so.0 for package: ORBit2
--> Running transaction check
---> Package avahi-glib.i386 0:0.6.22-10.fc9 set to be updated
---> Package libxml2.i386 0:2.6.32-2.fc9 set to be updated
---> Package openldap.i386 0:2.4.8-6.fc9 set to be updated
--> Processing Dependency: libsasl2.so.2 for package: openldap
---> Package avahi.i386 0:0.6.22-10.fc9 set to be updated
--> Processing Dependency: libdaemon.so.0 for package: avahi
---> Package ncurses-libs.i386 0:5.6-16.20080301.fc9 set to be updated
---> Package hal-libs.i386 0:0.5.11-2.fc9 set to be updated
---> Package readline.i386 0:5.2-13.fc9 set to be updated
---> Package libattr.i386 0:2.4.41-1.fc9 set to be updated
---> Package libIDL.i386 0:0.8.10-2.fc9 set to be updated
---> Package libacl.i386 0:2.2.47-1.fc9 set to be updated
---> Package esound-libs.i386 1:0.2.38-7.fc9 set to be updated
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4) for package: esound-libs
--> Processing Dependency: libasound.so.2(ALSA_0.9) for package: esound-libs
--> Processing Dependency: libasound.so.2 for package: esound-libs
---> Package audiofile.i386 1:0.2.6-8.fc9 set to be updated
--> Running transaction check
---> Package libdaemon.i386 0:0.12-3.fc9 set to be updated
---> Package alsa-lib.i386 0:1.0.16-3.fc9 set to be updated
---> Package cyrus-sasl-lib.i386 0:2.1.22-13.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 devhelp                 x86_64     0.19.1-3.fc9     updates           227 k
 firefox                 x86_64     3.0.1-1.fc9      updates           9.3 M
 xulrunner               x86_64     1.9.0.1-1.fc9    updates           8.7 M
 yelp                    x86_64     2.22.1-4.fc9     updates           876 k
Installing for dependencies:
 GConf2                  i386       2.22.0-1.fc9     fedora            1.6 M
 ORBit2                  i386       2.14.12-3.fc9    fedora            183 k
 alsa-lib                i386       1.0.16-3.fc9     fedora            407 k
 audiofile               i386       1:0.2.6-8.fc9    fedora            108 k
 avahi                   i386       0.6.22-10.fc9    fedora            245 k
 avahi-glib              i386       0.6.22-10.fc9    fedora             17 k
 bzip2-libs              i386       1.0.5-2.fc9      updates            38 k
 cyrus-sasl-lib          i386       2.1.22-13.fc9    fedora            1.1 M
 dbus-glib               i386       0.74-8.fc9       updates           165 k
 dbus-libs               i386       1.2.1-1.fc9      fedora            127 k
 esound-libs             i386       1:0.2.38-7.fc9   fedora             73 k
 gnome-vfs2              i386       2.22.0-1.fc9     fedora            1.1 M
 hal-libs                i386       0.5.11-2.fc9     updates            65 k
 hunspell                i386       1.2.1-7.fc9      updates           186 k
 lcms-libs               i386       1.17-5.fc9       updates           106 k
 libIDL                  i386       0.8.10-2.fc9     fedora             88 k
 libacl                  i386       2.2.47-1.fc9     fedora             22 k
 libattr                 i386       2.4.41-1.fc9     fedora             13 k
 libbonobo               i386       2.22.0-2.fc9     fedora            475 k
 libdaemon               i386       0.12-3.fc9       fedora             26 k
 libgnome                i386       2.22.0-3.fc9     fedora            977 k
 libxml2                 i386       2.6.32-2.fc9     updates           847 k
 ncurses-libs            i386       5.6-16.20080301.fc9  fedora            326 k
 nss                     i386       3.12.0.3-0.9.1.fc9  updates           1.1 M
 openldap                i386       2.4.8-6.fc9      updates           311 k
 popt                    i386       1.13-4.fc9       updates            39 k
 readline                i386       5.2-13.fc9       fedora            184 k
 sqlite                  i386       3.5.6-2.fc9      fedora            252 k
 xulrunner               i386       1.9-0.60.beta5.fc9  fedora            8.9 M

Transaction Summary
=============================================================================
Install     29 Package(s)         
Update       4 Package(s)         
Remove       0 Package(s)         

Total size: 38 M
Is this ok [y/N]: 

Dependencies are wrong so superfluous i386 stuff is selected whic doesn't even
work well:

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  package xulrunner-1.9-1.fc9.x86_64 (which is newer than
xulrunner-1.9-0.60.beta5.fc9.i386) is already installed

Error Summary
Comment 1 James Antill 2008-07-18 10:08:02 EDT
 There are a couple of things going on here, first the "error":

Installing for dependencies:
[...]
 xulrunner               i386       1.9-0.60.beta5.fc9  fedora            8.9 M
[...]
Transaction Check Error:
  package xulrunner-1.9-1.fc9.x86_64 (which is newer than
xulrunner-1.9-0.60.beta5.fc9.i386) is already installed


...there is an xulrunner-1.9-1.fc9.i386 in updates ... so I can only assume that
you've excluded it from that repo.?

 As for the generic "problem" there are two sides to that:

1. yum _used_ to install both foo.i386 and foo.x86_64 packages when you did "yum
install foo", it no longer does that by default.

2. rpm didn't/doesn't have ways of saying foo-devel.x86_64 depends on
foo.x86_64, it could only say it depended on "foo". This is fixed in rpm for
Fedora 10, and there is little we can do that we aren't already doing.

 You didn't list your yum version, but there are some changes to things yum can
do in the 3.2.17-2 in updates-testing ... so you might want to update to that.
However we can't "fix" your system automatically. What I'd suggest is:

1. Update to 3.2.17-2 in updates-testing.
2. Try "yum remove *.i386"
3. Look at what is going to be removed, you might well see that there is a cross
arch dependency in there ... if so do "yum install whatever.x86_64" and then
repeat until #2 is _just_ removing .i386 packages.

...you might also want to break down the removal, like "yum remove a*.i386" etc.
Comment 2 udo 2008-07-18 10:20:13 EDT
I am on x86_64.
I did not have a xulrunner.i386 nor do I need one to run firefox.x86_64.
Or is this a newly introduced dependency to increase the bloat?
My goal is to have as few as possible i386 rpms on my x86_64 system to keep
stuff as it should be.
Comment 3 Seth Vidal 2008-07-18 10:28:12 EDT
What's happening is that the x86_64 pkg is not in the repository and/or isn't
right and yum is pulling in the only other thing which can satisfy the
non-arch-specific dependency. Which is the i386 xulrunner.

The problem is with xulrunner in the repo you're using.
Comment 4 udo 2008-07-18 10:38:21 EDT
The repo is fedora/updates, as you can see.
Can I let someone know to fix this?
Or is a fix around the corner and can I just wait?
(the FF fix is `important`)
Comment 5 udo 2008-07-18 10:40:20 EDT
# yum update
Loaded plugins: merge-conf, refresh-packagekit
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: gecko-libs = 1.9 for package: nspluginwrapper
--> Processing Dependency: gecko-libs = 1.9 for package: nspluginwrapper
---> Package firefox.x86_64 0:3.0.1-1.fc9 set to be updated
---> Package yelp.x86_64 0:2.22.1-4.fc9 set to be updated
---> Package devhelp.x86_64 0:0.19.1-3.fc9 set to be updated
---> Package xulrunner.x86_64 0:1.9.0.1-1.fc9 set to be updated
--> Running transaction check
---> Package xulrunner.i386 0:1.9-0.60.beta5.fc9 set to be updated
--> Processing Dependency: libsmime3.so for package: xulrunner
--> Processing Dependency: libgconf-2.so.4 for package: xulrunner
--> Processing Dependency: liblcms.so.1 for package: xulrunner
--> Processing Dependency: libsqlite3.so.0 for package: xulrunner
(...)

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 devhelp                 x86_64     0.19.1-3.fc9     updates           227 k
 firefox                 x86_64     3.0.1-1.fc9      updates           9.3 M
 xulrunner               x86_64     1.9.0.1-1.fc9    updates           8.7 M
 yelp                    x86_64     2.22.1-4.fc9     updates           876 k
Installing for dependencies:
 GConf2                  i386       2.22.0-1.fc9     fedora            1.6 M
 ORBit2                  i386       2.14.12-3.fc9    fedora            183 k
 alsa-lib                i386       1.0.16-3.fc9     fedora            407 k
 audiofile               i386       1:0.2.6-8.fc9    fedora            108 k
 avahi                   i386       0.6.22-10.fc9    fedora            245 k
 avahi-glib              i386       0.6.22-10.fc9    fedora             17 k
 bzip2-libs              i386       1.0.5-2.fc9      updates            38 k
 cyrus-sasl-lib          i386       2.1.22-13.fc9    fedora            1.1 M
 dbus-glib               i386       0.74-8.fc9       updates           165 k
 dbus-libs               i386       1.2.1-1.fc9      fedora            127 k
 esound-libs             i386       1:0.2.38-7.fc9   fedora             73 k
 gnome-vfs2              i386       2.22.0-1.fc9     fedora            1.1 M
 hal-libs                i386       0.5.11-2.fc9     updates            65 k
 hunspell                i386       1.2.1-7.fc9      updates           186 k
 lcms-libs               i386       1.17-5.fc9       updates           106 k
 libIDL                  i386       0.8.10-2.fc9     fedora             88 k
 libacl                  i386       2.2.47-1.fc9     fedora             22 k
 libattr                 i386       2.4.41-1.fc9     fedora             13 k
 libbonobo               i386       2.22.0-2.fc9     fedora            475 k
 libdaemon               i386       0.12-3.fc9       fedora             26 k
 libgnome                i386       2.22.0-3.fc9     fedora            977 k
 libxml2                 i386       2.6.32-2.fc9     updates           847 k
 ncurses-libs            i386       5.6-16.20080301.fc9  fedora            326 k
 nss                     i386       3.12.0.3-0.9.1.fc9  updates           1.1 M
 openldap                i386       2.4.8-6.fc9      updates           311 k
 popt                    i386       1.13-4.fc9       updates            39 k
 readline                i386       5.2-13.fc9       fedora            184 k
 sqlite                  i386       3.5.6-2.fc9      fedora            252 k
 xulrunner               i386       1.9-0.60.beta5.fc9  fedora            8.9 M

Transaction Summary
=============================================================================
Install     29 Package(s)         
Update       4 Package(s)         
Remove       0 Package(s)         

Total download size: 38 M
Is this ok [y/N]: 
Exiting on user Command
Complete!
[root@surfplank2 xf86-video-radeonhd]# rpm -qi xulrunner
Name        : xulrunner                    Relocations: (not relocatable)
Version     : 1.9                               Vendor: Fedora Project
Release     : 1.fc9                         Build Date: Tue 17 Jun 2008 06:38:35
PM CEST
Install Date: Wed 18 Jun 2008 04:43:53 PM CEST      Build Host: x86-2
Group       : Applications/Internet         Source RPM: xulrunner-1.9-1.fc9.src.rpm
Size        : 23625662                         License: MPLv1.1 or GPLv2+ or LGPLv2+
Signature   : DSA/SHA1, Tue 17 Jun 2008 10:52:19 PM CEST, Key ID b44269d04f2a6fd2
Packager    : Fedora Project
URL         : http://www.mozilla.org/projects/xulrunner/
Summary     : XUL Runtime for Gecko Applications
Description :
XULRunner provides the XUL Runtime environment for Gecko applications.
[root@surfplank2 xf86-video-radeonhd]# 

Comment 6 udo 2008-07-18 10:42:08 EDT
[root@surfplank2 xf86-video-radeonhd]# rpm -qi xulrunner.i386
package xulrunner.i386 is not installed
[root@surfplank2 xf86-video-radeonhd]# rpm -qi xulrunner.x86_64
Name        : xulrunner                    Relocations: (not relocatable)
Version     : 1.9                               Vendor: Fedora Project
Release     : 1.fc9                         Build Date: Tue 17 Jun 2008 06:38:35
PM CEST
Install Date: Wed 18 Jun 2008 04:43:53 PM CEST      Build Host: x86-2
Group       : Applications/Internet         Source RPM: xulrunner-1.9-1.fc9.src.rpm
Size        : 23625662                         License: MPLv1.1 or GPLv2+ or LGPLv2+
Signature   : DSA/SHA1, Tue 17 Jun 2008 10:52:19 PM CEST, Key ID b44269d04f2a6fd2
Packager    : Fedora Project
URL         : http://www.mozilla.org/projects/xulrunner/
Summary     : XUL Runtime for Gecko Applications
Description :
XULRunner provides the XUL Runtime environment for Gecko applications.
Comment 7 James Antill 2008-07-18 10:42:09 EDT
*** Bug 455868 has been marked as a duplicate of this bug. ***
Comment 8 shrek-m 2008-07-18 11:39:16 EDT
nspluginwrapper is the problem.


# rpm -e nspluginwrapper.i386
nothing changed

# rpm -e nspluginwrapper.x86_64
it is ok and you can update the x86_64 packages



# LANG=C yum install nspluginwrapper.x86_64
Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 nspluginwrapper         x86_64     1.1.0-2.fc9      updates           118 k
Installing for dependencies:
 GConf2                  i386       2.22.0-1.fc9     fedora            1.6 M
 ORBit2                  i386       2.14.12-3.fc9    fedora            183 k
 alsa-lib                i386       1.0.16-3.fc9     fedora            407 k
 audiofile               i386       1:0.2.6-8.fc9    fedora            108 k
 avahi                   i386       0.6.22-10.fc9    fedora            245 k
 avahi-glib              i386       0.6.22-10.fc9    fedora             17 k
 bzip2-libs              i386       1.0.5-2.fc9      updates            38 k
 cyrus-sasl-lib          i386       2.1.22-13.fc9    fedora            1.1 M
 dbus-glib               i386       0.74-8.fc9       updates           165 k
 esound-libs             i386       1:0.2.38-7.fc9   fedora             73 k
 gnome-vfs2              i386       2.22.0-1.fc9     fedora            1.1 M
 hunspell                i386       1.2.1-7.fc9      updates           186 k
 lcms-libs               i386       1.17-5.fc9       updates           106 k
 libIDL                  i386       0.8.10-2.fc9     fedora             88 k
 libacl                  i386       2.2.47-1.fc9     fedora             22 k
 libattr                 i386       2.4.41-1.fc9     fedora             13 k
 libbonobo               i386       2.22.0-2.fc9     fedora            475 k
 libdaemon               i386       0.12-3.fc9       fedora             26 k
 libgnome                i386       2.22.0-3.fc9     fedora            977 k
 nss                     i386       3.12.0.3-0.9.1.fc9  updates           1.1 M
 openldap                i386       2.4.8-6.fc9      updates           311 k
 popt                    i386       1.13-4.fc9       updates            39 k
 readline                i386       5.2-13.fc9       fedora            184 k
 sqlite                  i386       3.5.6-2.fc9      fedora            252 k
 xulrunner               i386       1.9-0.60.beta5.fc9  fedora            8.9 M

Transaction Summary
=============================================================================
Install     26 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total size: 18 M
Total download size: 18 M
Is this ok [y/N]: n
Exiting on user Command
Complete!
Comment 9 udo 2008-07-18 12:21:10 EDT
Yes, that is right.
But I need nspluginwrapper, it is essential for a FF on x86_64 setup.
When I follow your tip and reinstall nspluginwrapper.i386/.x86_64 there is still
the load of dependencies because of the nice wau of formulating dependencies.
Would I now start bugging the nspluginrwapper rpm maintainer?

Or am I missing anything?
Comment 10 udo 2008-07-18 12:29:52 EDT
# yum install nspluginwrapper.x86_64 nspluginwrapper.i386
Loaded plugins: merge-conf, refresh-packagekit
Excluding Packages in global exclude list
Finished
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package nspluginwrapper.x86_64 0:1.1.0-2.fc9 set to be updated
--> Processing Dependency: gecko-libs = 1.9 for package: nspluginwrapper
---> Package nspluginwrapper.i386 0:1.1.0-2.fc9 set to be updated
--> Running transaction check
---> Package xulrunner.i386 0:1.9-0.60.beta5.fc9 set to be updated
--> Processing Dependency: libsmime3.so for package: xulrunner
--> Processing Dependency: libgconf-2.so.4 for package: xulrunner
--> Processing Dependency: liblcms.so.1 for package: xulrunner
(...)
Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 nspluginwrapper         x86_64     1.1.0-2.fc9      updates           118 k
 nspluginwrapper         i386       1.1.0-2.fc9      updates           130 k
Installing for dependencies:
 GConf2                  i386       2.22.0-1.fc9     fedora            1.6 M
 ORBit2                  i386       2.14.12-3.fc9    fedora            183 k
 alsa-lib                i386       1.0.16-3.fc9     fedora            407 k
 audiofile               i386       1:0.2.6-8.fc9    fedora            108 k
 avahi                   i386       0.6.22-10.fc9    fedora            245 k
 avahi-glib              i386       0.6.22-10.fc9    fedora             17 k
 bzip2-libs              i386       1.0.5-2.fc9      updates            38 k
 cyrus-sasl-lib          i386       2.1.22-13.fc9    fedora            1.1 M
 dbus-glib               i386       0.74-8.fc9       updates           165 k
 dbus-libs               i386       1.2.1-1.fc9      fedora            127 k
 esound-libs             i386       1:0.2.38-7.fc9   fedora             73 k
 gnome-vfs2              i386       2.22.0-1.fc9     fedora            1.1 M
 hal-libs                i386       0.5.11-2.fc9     updates            65 k
 hunspell                i386       1.2.1-7.fc9      updates           186 k
 lcms-libs               i386       1.17-5.fc9       updates           106 k
 libIDL                  i386       0.8.10-2.fc9     fedora             88 k
 libacl                  i386       2.2.47-1.fc9     fedora             22 k
 libattr                 i386       2.4.41-1.fc9     fedora             13 k
 libbonobo               i386       2.22.0-2.fc9     fedora            475 k
 libdaemon               i386       0.12-3.fc9       fedora             26 k
 libgnome                i386       2.22.0-3.fc9     fedora            977 k
 libxml2                 i386       2.6.32-2.fc9     updates           847 k
 ncurses-libs            i386       5.6-16.20080301.fc9  fedora            326 k
 nss                     i386       3.12.0.3-0.9.1.fc9  updates           1.1 M
 openldap                i386       2.4.8-6.fc9      updates           311 k
 popt                    i386       1.13-4.fc9       updates            39 k
 readline                i386       5.2-13.fc9       fedora            184 k
 sqlite                  i386       3.5.6-2.fc9      fedora            252 k
 xulrunner               i386       1.9-0.60.beta5.fc9  fedora            8.9 M

Transaction Summary
=============================================================================
Install     31 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 19 M
Is this ok [y/N]: y
Downloading Packages:
(...)
(31/31): xulrunner-1.9-0.60.beta5.fc9.i386.rpm                                 
                                                     | 8.9 MB     01:11     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test

So yes, we have a problem.
It doesn't work as designed.
It is a bug somewhere.
How can I help fix this?
Transaction Check Error:
  package xulrunner-1.9.0.1-1.fc9.x86_64 (which is newer than
xulrunner-1.9-0.60.beta5.fc9.i386) is already installed
  file /usr/bin/xulrunner from install of xulrunner-1.9-0.60.beta5.fc9.i386
conflicts with file from package xulrunner-1.9.0.1-1.fc9.x86_64

Error Summary
-------------

[root@surfplank2 xf86-video-radeonhd]# 
Comment 11 udo 2008-07-18 12:38:22 EDT
It is even worse:

Just do rpm -Uvh --nodeps nspluginwrapper.*
(for i386 and x86_64) and stuff will work.

Comment 12 shrek-m 2008-07-18 12:58:28 EDT
nspluginwrapper-1.1.0-3.fc9.i386  will be the next problem.

http://koji.fedoraproject.org/koji/buildinfo?buildID=56605


x86_64 is no longer a problem but

# LANG=C rpm -Uvh nspluginwrapper-1.1.0-3.fc9.i386.rpm 
error: Failed dependencies:
	libcurl.so.4 is needed by nspluginwrapper-1.1.0-3.fc9.i386
# rpm -qa libcurl
libcurl-7.18.2-1.fc9.x86_64



and here we are again :(

# LANG=C yum install libcurl.i386

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 libcurl                 i386       7.18.2-1.fc9     updates           145 k
Installing for dependencies:
 cyrus-sasl-lib          i386       2.1.22-13.fc9    fedora            1.1 M
 libidn                  i386       0.6.14-7         fedora            211 k
 nss                     i386       3.12.0.3-0.9.1.fc9  updates           1.1 M
 openldap                i386       2.4.8-6.fc9      updates           311 k
 readline                i386       5.2-13.fc9       fedora            184 k
 sqlite                  i386       3.5.6-2.fc9      fedora            252 k

Transaction Summary
=============================================================================
Install      7 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 3.4 M
Is this ok [y/N]: n
Exiting on user Command
Complete!

Note You need to log in before you can comment on or make changes to this bug.