Bug 455967 - Volume group not found on boot
Volume group not found on boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-19 09:52 EDT by Vegard Nossum
Modified: 2008-08-06 11:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 20:33:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vegard Nossum 2008-07-19 09:52:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1

Description of problem:
After upgrading from 2.6.25.9-76.fc9.i686 which had a wireless problem, I cannot boot because the volume group LogVol??/VolGroup?? or something is not found.

The old 2.6.25.9-76.fc9.i686 works fine, as does a self-compiled 2.6.26.

Is this a problem with the initrd?

Version-Release number of selected component (if applicable):
2.6.25.10-86.fc9.i686

How reproducible:
Always


Steps to Reproduce:
1. Boot

Actual Results:


Expected Results:


Additional info:
# pvdisplay 
  --- Physical volume ---
  PV Name               /dev/sda5
  VG Name               VolGroup00
  PV Size               69.32 GB / not usable 6.48 MB
  Allocatable           yes 
  PE Size (KByte)       32768
  Total PE              2218
  Free PE               1
  Allocated PE          2217
  PV UUID               hWBIdF-2y1t-ZY7R-38wG-Wbh5-bxNg-Hzu8eH

# vgdisplay 
  --- Volume group ---
  VG Name               VolGroup00
  System ID             
  Format                lvm2
  Metadata Areas        1
  Metadata Sequence No  3
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                2
  Open LV               2
  Max PV                0
  Cur PV                1
  Act PV                1
  VG Size               69.31 GB
  PE Size               32.00 MB
  Total PE              2218
  Alloc PE / Size       2217 / 69.28 GB
  Free  PE / Size       1 / 32.00 MB
  VG UUID               HeyCyF-bmMV-uyXC-OWoA-2tks-sd68-0sTXZc

# lvdisplay 
  --- Logical volume ---
  LV Name                /dev/VolGroup00/LogVol00
  VG Name                VolGroup00
  LV UUID                02Je9w-UNZq-80Yv-DmCx-D2ea-GnUP-ZXBm5T
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                67.34 GB
  Current LE             2155
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           254:0
   
  --- Logical volume ---
  LV Name                /dev/VolGroup00/LogVol01
  VG Name                VolGroup00
  LV UUID                U3NacY-Fav5-kO6G-qEsT-n3ZK-o49a-U0BLz1
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                1.94 GB
  Current LE             62
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           254:1

# From /etc/grub.conf
title Fedora (2.6.25.10-86.fc9.i686)
        root (hd0,2)
        kernel /vmlinuz-2.6.25.10-86.fc9.i686 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.25.10-86.fc9.i686.img

title Fedora (2.6.25.9-76.fc9.i686)
        root (hd0,2)
        kernel /vmlinuz-2.6.25.9-76.fc9.i686 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.25.9-76.fc9.i686.img
Comment 1 Chuck Ebbert 2008-07-21 23:33:08 EDT
Can you upload the old and new initrd? (Or better yet look inside them and
compare the init scripts?)
Comment 2 Vegard Nossum 2008-07-22 02:50:34 EDT
This is the diff between the inits. The other files in the initrds seem to all
be binary files. Please let me know if you need any more information.

diff -r -u initrd-2.6.25.9/init initrd-2.6.25.10/init
--- initrd-2.6.25.9/init        2008-07-22 10:47:35.000000000 +0200
+++ initrd-2.6.25.10/init       2008-07-22 10:47:42.000000000 +0200
@@ -48,16 +48,6 @@
 mount -t usbfs /proc/bus/usb /proc/bus/usb
 echo "Loading ext3 module"
 modprobe -q ext3
-echo "Loading scsi_mod module"
-modprobe -q scsi_mod
-echo "Loading sd_mod module"
-modprobe -q sd_mod
-echo "Loading libata module"
-modprobe -q libata
-echo "Loading ahci module"
-modprobe -q ahci
-echo Waiting for driver initialization.
-stabilized --hash --interval 250 /proc/scsi/scsi
 echo "Loading dm-mod module"
 modprobe -q dm-mod
 echo "Loading dm-mirror module"
@@ -68,13 +58,11 @@
 modprobe -q dm-snapshot
 echo Making device-mapper control node
 mkdmnod
-modprobe scsi_wait_scan
-rmmod scsi_wait_scan
 mkblkdevs
 echo Scanning logical volumes
 lvm vgscan --ignorelockingfailure
 echo Activating logical volumes
-lvm vgchange -ay --ignorelockingfailure  VolGroup00
+lvm vgchange -ay --ignorelockingfailure   VolGroup00
 resume /dev/VolGroup00/LogVol01
 echo Creating root device.
 mkrootdev -t ext3 -o defaults,ro /dev/VolGroup00/LogVol00
Comment 3 Chuck Ebbert 2008-07-24 23:35:05 EDT
I don't have a clue why mkinitrd would omit all of the SCSI modules. Reassigning
to mkinitrd.
Comment 4 Vegard Nossum 2008-07-24 23:47:39 EDT
Hm. When is the initrd built, at install time ("yum install kernel") or when the
kernel rpm is built?

If at install time, I might have been installing the kernel while running a
plain v2.6.26 with no modules (everything built in). This was of course because
wireless did not work on the previous Fedora kernel. Maybe this is why mkinitrd
failed to pick it up?
Comment 5 Vegard Nossum 2008-07-27 13:58:59 EDT
FYI, 2.6.25.11-97.fc9.i686 doesn't work either.
Comment 6 Chuck Ebbert 2008-07-29 21:39:15 EDT
(In reply to comment #4)
> Hm. When is the initrd built, at install time ("yum install kernel") or when the
> kernel rpm is built?
> 
> If at install time, I might have been installing the kernel while running a
> plain v2.6.26 with no modules (everything built in). This was of course because
> wireless did not work on the previous Fedora kernel. Maybe this is why mkinitrd
> failed to pick it up?

It's built at install time and figures out which modules are needed from what is
already loaded while installing the kernel.

I think we can close this as NOTABUG?
Comment 7 Vegard Nossum 2008-07-30 06:42:05 EDT
(In reply to comment #6)
> I think we can close this as NOTABUG?

Well, I would really appreciate any hints on how to get a working Fedora kernel :-/

Can I, for example, install an older kernel (which has wireless too), then
install the newer kernel while the old one is booted (in order to get the SCSI
modules in the initrd)? Or can I force the initrd to include the SCSI modules in
any other way?

Thanks for the help.
Comment 8 Chuck Ebbert 2008-08-01 20:33:58 EDT
look at the manpage for mkinitrd... once you get the right modules back in there
(using the --with option and possibly some others) the next kernel install
should pick them up automatically.

Next time you build your own kernel, build it the same way as the fedora one and
you won't have this problem.   :)
Comment 9 Vegard Nossum 2008-08-06 11:21:26 EDT
(In reply to comment #8)
> look at the manpage for mkinitrd... once you get the right modules back in there
> (using the --with option and possibly some others) the next kernel install
> should pick them up automatically.
> 
> Next time you build your own kernel, build it the same way as the fedora one and
> you won't have this problem.   :)

Thanks.

For future reference, another workaround is this:

1. Boot the Fedora install DVD
2. Choose the "rescue" option in the grub boot menu
3. Mount the installed system and chroot (text-mode menu system will guide this process)
(4. yum remove kernel -- only if newest kernel is already installed)
5. yum install kernel

Note You need to log in before you can comment on or make changes to this bug.