Bug 455980 - nfsnobody gid is wrong
nfsnobody gid is wrong
Status: CLOSED DUPLICATE of bug 485379
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-19 14:33 EDT by Allen Kistler
Modified: 2009-03-25 20:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 20:15:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Allen Kistler 2008-07-19 14:33:26 EDT
Description of problem:
nfsnobody gid is 499 in /etc/passwd and /etc/group.  However all_squash on
exports still uses 65534 (which I think is correct).

Version-Release number of selected component (if applicable):
nfs-utils-1.1.2-2.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Look in /etc/passwd and /etc/group
  
Actual results:
gid is listed as 499

Expected results:
gid is listed as 65534

Additional info:
Exporting a writable directory as all_squash, mounting it on another machine,
and creating a file from that machine causes the file to be created with gid
65534.  However then "ls -l" lists its ownership as "nfsnobody 65534" instead of
as "nfsnobody nfsnobody."
Comment 1 Allen Kistler 2008-08-07 04:16:10 EDT
Oops.  The "right" wrong gid is 492, but it's still not 65534.
Comment 2 Steve Dickson 2008-08-07 11:59:42 EDT
hmm... something must have changed where the same uid and gid are
no longer used...
Comment 3 Allen Kistler 2009-03-25 20:15:05 EDT
Since I've added a patch for Bug 485379, which is the same as this one except for F11-test, I'm closing this one in favor of that one.

*** This bug has been marked as a duplicate of bug 485379 ***

Note You need to log in before you can comment on or make changes to this bug.