Bug 456014 - Rhythmbox will not write correctly to ipod recently
Rhythmbox will not write correctly to ipod recently
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-20 13:20 EDT by Brad Longo
Modified: 2009-03-29 19:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-29 19:59:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Longo 2008-07-20 13:20:06 EDT
Description of problem:
After completion of writing new information to my brothers Ipod Nano, rhythmbox
has not once successfully ejected the device.  The only way I can do this is to
close rhythmbox, and eject it from my desktop or my computer.  Using the umount
command also does not eject the ipod, but erases it record in /etc/fstab so the
computer still thinks it there.  I know the ipod is not disconnected though
because on the ipod's screen it still says the ipod is connected.

I have filed this bug with high severity because whether or not the ipod umounts
successfully it does not know that there is music on the device.  However, when
plugged into rhythmbox the music shows up as being on the ipod.  

Version-Release number of selected component (if applicable):
rhythmbox-0.11.5-13.fc9.i386
ipod nano model no. A1236 

How reproducible:
every time

Steps to Reproduce:
1. make changes to ipod with rhythmbox
2. unmount ipod
3. 
  
Actual results:
Music is written but device does not unmount correctly so music cannot be viewed
on ipod device.

Expected results:
After writing information to ipod and then umounting ipod I should be able to
find the all the music files.

Additional info:
I have an older model of the ipod nano and recently my ipod has been having
isues unmounting from rhythmbox as well.  However my music is still accessible
on the device. I never used to have such issues.
Comment 1 Bastien Nocera 2008-07-20 15:26:18 EDT
Which version are you using?

Try at the very least the current updates-testing version (0.11.6).
Comment 2 Brad Longo 2008-07-20 21:06:21 EDT
[brad@localhost ~]$ rpm -q rhythmbox
rhythmbox-0.11.5-13.fc9.i386

I'll download the 0.11.6 version, and see what happens.
Comment 3 Bastien Nocera 2008-07-21 04:59:05 EDT
Please leave the bug as NEEDINFO until you provide the information requested.
Thanks.
Comment 4 Brad Longo 2008-07-23 15:14:33 EDT
I just installed and tried rhythmbox version 0.11.6 and it seems to have no
effect at all.  Rhythmbox still tells me that music is on the ipod, but when
disconnected the ipod doesn't say there any music there.  In addition, the ipod
still won't unmount correctly from rhythmbox.
Comment 5 Bastien Nocera 2009-03-24 13:07:03 EDT
Could you please attach the output of "rhythmbox -d" when reproducing the problem? It would also be helpful if you could try with a more recent version of rhythmbox.
Comment 6 Brad Longo 2009-03-29 19:59:27 EDT
I am closing this bug since I am no longer having this issue.  Thanks to those who helped.

Note You need to log in before you can comment on or make changes to this bug.