Bug 456058 - RealPlayer plugin doesn't work with firefox 3.0.1-1
RealPlayer plugin doesn't work with firefox 3.0.1-1
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: realplayer (Show other bugs)
4.7
i386 Linux
low Severity low
: rc
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-21 05:31 EDT by lihuang
Modified: 2008-07-21 22:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-21 22:12:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lihuang 2008-07-21 05:31:19 EDT
Description of problem:
RealPlayer plugin doesn't work with firefox 3.0.1-1

Version-Release number of selected component (if applicable):
firefox-3.0.1-1.el4
RealPlayer-10.0.9.2

How reproducible:
Everytime

Steps to Reproduce:
1. Install RealPlayer: RealPLayer-10.0.9-2.i386.rpm
2. lanuch firefox
3. Type ' about:plugins' in URL to check plugin's information
  
Actual results:
1. The RealPlayer plugin's information is not shown in the browser window

Expected results:
1. The RealPlayer plugin's information is  shown in the browser window

Additional info:
The RealPlayer plugin works well with seamonkey-1.0.9-24.el4.
Comment 1 Bastien Nocera 2008-07-21 05:36:15 EDT
What's the output of "firefox -debug" when reproducing this problem? Are you
running on i386 or x86_64?
Comment 2 lihuang 2008-07-21 05:49:39 EDT
Hi .Bastien, on my test machine nothing output when reproducing this problem.
and it's i386
Comment 3 Bastien Nocera 2008-07-21 06:06:45 EDT
That means there are no errors on the RealPlayer side, and that reinstalling the
RealPlayer RPM should install the .so files in the right location, and fix the
problem.

Nothing that I can do about it...
Comment 4 lihuang 2008-07-21 21:36:43 EDT
Tried again, but still *failed*

[root@jupiter plugins]# pwd
/usr/lib/mozilla/plugins
[root@jupiter plugins]# ls -rtl
total 64
-rwxr-xr-x  1 root root  5086 Jul 27  2007 nphelix.xpt
-rwxr-xr-x  1 root root 40640 Aug  9  2007 nphelix.so
lrwxrwxrwx  1 root root    34 Jul 21 19:27 libjavaplugin.so ->
/etc/alternatives/libjavaplugin.so
lrwxrwxrwx  1 root root    39 Jul 21 21:57 libflashplayer.so ->
/usr/lib/flash-plugin/libflashplayer.so
[root@jupiter plugins]# rpm -qa | grep RealPlay
RealPlayer-10.0.9-2
[root@jupiter plugins]# rpm -e RealPlayer-10.0.9-2
[root@jupiter plugins]# ls -rtl
lrwxrwxrwx  1 root root    34 Jul 21 19:27 libjavaplugin.so ->
/etc/alternatives/libjavaplugin.so
lrwxrwxrwx  1 root root    39 Jul 21 21:57 libflashplayer.so ->
/usr/lib/flash-plugin/libflashplayer.so
[root@jupiter plugins]# rpm -ivh ~root/Desktop/RealPlayer-10.0.9-2.i386.rpm
warning: /root/Desktop/RealPlayer-10.0.9-2.i386.rpm: V3 DSA signature: NOKEY,
key ID db42a60e
Preparing...                ########################################### [100%]
   1:RealPlayer             ########################################### [100%]
[root@jupiter plugins]# ls -rtl
-rwxr-xr-x  1 root root  5086 Jul 27  2007 nphelix.xpt
-rwxr-xr-x  1 root root 40640 Aug  9  2007 nphelix.so
lrwxrwxrwx  1 root root    34 Jul 21 19:27 libjavaplugin.so ->
/etc/alternatives/libjavaplugin.so
lrwxrwxrwx  1 root root    39 Jul 21 21:57 libflashplayer.so ->
/usr/lib/flash-plugin/libflashplayer.so
Comment 5 Nicole Dai 2008-07-21 22:12:06 EDT
Resolve the bug for the problem should be caused by Bug 456099. Please reopen if
you have question on it.

Note You need to log in before you can comment on or make changes to this bug.