Bug 45606 - rpm-4x output is uninformative
Summary: rpm-4x output is uninformative
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-23 13:43 UTC by Tony Hunter
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-25 13:42:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tony Hunter 2001-06-23 13:43:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Win95; U)

Description of problem:
Running 'rpm -Fvh *rpm > freshen.log' where numerous rpms exist in a 
directory does not output the package names for rpms which were freshened. 
Output is limited to hash marks and non-informative text.
This is a symptom of rpm-4x, rather than RH7.1 specifically, as the same 
problem is reproduceable on RH6.2 updated to rpm-4.x

How reproducible:
Always

Steps to Reproduce:
1.rpm -Fvh *rpm   or
2.rpm -Fvh *rpm > freshen-log or
3.rpm -Fvh *rpm > freshen-log 2>&1
	

Actual Results:  Preparing...                
##########################################################################
#
######################## [100%]
##########################################################################
#
######################## [100%]                   

Expected Results:  glibc            
##################################################
glibc-devel      ##################################################


Additional info:

The expected results are what is output with rpm-3x and is certainly more 
desireable/informative output than the output from rpm-4x. Even better 
output would include not only package names but version numbers.

Comment 1 Michael Schwendt 2001-06-25 13:42:42 UTC
Can't reproduce it with step 1, which is working correctly and gives the package
name in the first column:

# rpm -Fvh *.rpm
Preparing...                ########################################### [100%]
   1:fetchmail              ########################################### [100%]

Steps 2 and 3 give bad output, however. Also with -ivh.


Comment 2 Jeff Johnson 2001-06-25 18:51:22 UTC
Take the -h flaf off (i.e. use "-Fv") to get just the package names
w/o the screen progress bar clutter.


Note You need to log in before you can comment on or make changes to this bug.