Bug 456121 - dbus multilib brokeness breaks updates
dbus multilib brokeness breaks updates
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
9
x86_64 Linux
urgent Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-21 12:30 EDT by Jonathan Underwood
Modified: 2013-03-05 22:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-21 21:10:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2008-07-21 12:30:53 EDT
Description of problem:
Currently the nspluginwrapper updates pull in a load of i386 stuff on x86_64
(which itself is probably a bug). However, this triggers a bug in dbus when it
tries to install dbus-libs for i386 on x86_64, as seen below. 

Labelling this as urgent, as it is blocking security updates!


# yum -y update
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * livna: rpm.livna.org
 * fedora: www.mirrorservice.org
 * adobe-linux-i386: linuxdownload.adobe.com
 * updates: www.mirrorservice.org
livna                                                    | 2.1 kB     00:00     
fedora                                                   | 2.4 kB     00:00     
adobe-linux-i386                                         |  951 B     00:00     
updates                                                  | 2.3 kB     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package device-mapper-multipath.x86_64 0:0.4.7-16.fc9 set to be updated
---> Package nspluginwrapper.x86_64 0:1.1.0-3.fc9 set to be updated
--> Processing Dependency: gecko-libs = 1.9 for package: gxine
---> Package firefox.x86_64 0:3.0.1-1.fc9 set to be updated
---> Package kpartx.x86_64 0:0.4.7-16.fc9 set to be updated
---> Package system-config-language.noarch 0:1.3.1-2.fc9 set to be updated
---> Package binutils.x86_64 0:2.18.50.0.6-4.fc9 set to be updated
---> Package libvirt-python.x86_64 0:0.4.4-2.fc9 set to be updated
---> Package totem-mozplugin.x86_64 0:2.23.2-5.fc9 set to be updated
---> Package totem-nautilus.x86_64 0:2.23.2-5.fc9 set to be updated
---> Package xen-libs.x86_64 0:3.2.0-14.fc9 set to be updated
---> Package yelp.x86_64 0:2.22.1-4.fc9 set to be updated
---> Package cpio.x86_64 0:2.9-8.fc9 set to be updated
---> Package dmraid.x86_64 0:1.0.0.rc14-8.fc9 set to be updated
---> Package totem-xine.x86_64 0:2.23.2-5.fc9 set to be updated
---> Package totem.x86_64 0:2.23.2-5.fc9 set to be updated
---> Package nspluginwrapper.i386 0:1.1.0-3.fc9 set to be updated
--> Processing Dependency: libcurl.so.4 for package: nspluginwrapper
---> Package xulrunner.x86_64 0:1.9.0.1-1.fc9 set to be updated
---> Package libvirt.x86_64 0:0.4.4-2.fc9 set to be updated
---> Package totem-gstreamer.x86_64 0:2.23.2-5.fc9 set to be updated
---> Package selinux-policy.noarch 0:3.3.1-78.fc9 set to be updated
---> Package selinux-policy-targeted.noarch 0:3.3.1-78.fc9 set to be updated
--> Running transaction check
---> Package libcurl.i386 0:7.18.2-1.fc9 set to be updated
--> Processing Dependency: libnss3.so(NSS_3.9.3) for package: libcurl
--> Processing Dependency: libnss3.so(NSS_3.5) for package: libcurl
--> Processing Dependency: libssl3.so for package: libcurl
--> Processing Dependency: libnss3.so(NSS_3.12) for package: libcurl
--> Processing Dependency: libidn.so.11 for package: libcurl
--> Processing Dependency: libssl3.so(NSS_3.11.4) for package: libcurl
--> Processing Dependency: libnss3.so(NSS_3.4) for package: libcurl
--> Processing Dependency: libnss3.so for package: libcurl
--> Processing Dependency: libssl3.so(NSS_3.2) for package: libcurl
--> Processing Dependency: libsmime3.so for package: libcurl
--> Processing Dependency: libnss3.so(NSS_3.2) for package: libcurl
--> Processing Dependency: libssl3.so(NSS_3.4) for package: libcurl
--> Processing Dependency: libnss3.so(NSS_3.3) for package: libcurl
---> Package xulrunner.i386 0:1.9-0.60.beta5.fc9 set to be updated
--> Processing Dependency: libgconf-2.so.4 for package: xulrunner
--> Processing Dependency: libsqlite3.so.0 for package: xulrunner
--> Processing Dependency: libbonobo-activation.so.4 for package: xulrunner
--> Processing Dependency: libgnome-2.so.0 for package: xulrunner
--> Processing Dependency: libgnomevfs-2.so.0 for package: xulrunner
--> Processing Dependency: libbz2.so.1 for package: xulrunner
--> Processing Dependency: libbonobo-2.so.0 for package: xulrunner
--> Processing Dependency: libORBit-2.so.0 for package: xulrunner
--> Processing Dependency: libhunspell.so.1 for package: xulrunner
--> Processing Dependency: libdbus-glib-1.so.2 for package: xulrunner
--> Processing Dependency: libdbus-1.so.3 for package: xulrunner
--> Running transaction check
---> Package bzip2-libs.i386 0:1.0.5-2.fc9 set to be updated
---> Package gnome-vfs2.i386 0:2.22.0-1.fc9 set to be updated
--> Processing Dependency: libavahi-client.so.3 for package: gnome-vfs2
--> Processing Dependency: libattr.so.1 for package: gnome-vfs2
--> Processing Dependency: libhal-storage.so.1 for package: gnome-vfs2
--> Processing Dependency: libacl.so.1 for package: gnome-vfs2
--> Processing Dependency: libavahi-glib.so.1 for package: gnome-vfs2
--> Processing Dependency: libavahi-common.so.3 for package: gnome-vfs2
--> Processing Dependency: libacl.so.1(ACL_1.0) for package: gnome-vfs2
--> Processing Dependency: libhal.so.1 for package: gnome-vfs2
---> Package GConf2.i386 0:2.22.0-1.fc9 set to be updated
---> Package hunspell.i386 0:1.2.1-7.fc9 set to be updated
---> Package nss.i386 0:3.12.0.3-0.9.1.fc9 set to be updated
---> Package dbus-glib.i386 0:0.74-8.fc9 set to be updated
---> Package dbus-libs.i386 0:1.2.1-1.fc9 set to be updated
--> Processing Dependency: dbus = 1.2.1-1.fc9 for package: dbus-libs
---> Package libgnome.i386 0:2.22.0-3.fc9 set to be updated
---> Package libbonobo.i386 0:2.22.0-2.fc9 set to be updated
---> Package ORBit2.i386 0:2.14.12-3.fc9 set to be updated
--> Processing Dependency: libIDL-2.so.0 for package: ORBit2
---> Package libidn.i386 0:0.6.14-7 set to be updated
---> Package sqlite.i386 0:3.5.6-2.fc9 set to be updated
--> Running transaction check
---> Package avahi.i386 0:0.6.22-10.fc9 set to be updated
--> Processing Dependency: libdaemon.so.0 for package: avahi
---> Package hal-libs.i386 0:0.5.11-2.fc9 set to be updated
---> Package libattr.i386 0:2.4.41-1.fc9 set to be updated
---> Package avahi-glib.i386 0:0.6.22-10.fc9 set to be updated
---> Package dbus-libs.i386 0:1.2.1-1.fc9 set to be updated
--> Processing Dependency: dbus = 1.2.1-1.fc9 for package: dbus-libs
---> Package libIDL.i386 0:0.8.10-2.fc9 set to be updated
---> Package libacl.i386 0:2.2.47-1.fc9 set to be updated
--> Running transaction check
---> Package libdaemon.i386 0:0.12-3.fc9 set to be updated
---> Package dbus-libs.i386 0:1.2.1-1.fc9 set to be updated
--> Processing Dependency: dbus = 1.2.1-1.fc9 for package: dbus-libs
--> Finished Dependency Resolution
dbus-libs-1.2.1-1.fc9.i386 from fedora has depsolving problems
  --> Missing Dependency: dbus = 1.2.1-1.fc9 is needed by package
dbus-libs-1.2.1-1.fc9.i386 (fedora)
Error: Missing Dependency: dbus = 1.2.1-1.fc9 is needed by package
dbus-libs-1.2.1-1.fc9.i386 (fedora)
Comment 1 David Zeuthen 2008-07-21 13:48:06 EDT
FWIW, this works just fine for me on Rawhide. 

$ rpm -qa|grep dbus
dbus-libs-1.2.1-6.fc10.x86_64
dbus-libs-1.2.1-6.fc10.i386
dbus-python-0.82.4-3.fc10.x86_64
dbus-glib-devel-0.76-1.fc10.x86_64
dbus-1.2.1-6.fc10.x86_64
dbus-glib-debuginfo-0.74-6.fc9.x86_64
dbus-glib-0.76-1.fc10.x86_64
dbus-devel-1.2.1-6.fc10.x86_64
dbus-x11-1.2.1-6.fc10.x86_64

I think PEBCAK. Feel free to reopen if you have evidence suggesting otherwise.
Comment 2 Jonathan Underwood 2008-07-21 19:59:49 EDT
Reopening.

How can this be PEBCAK[sic]? F9 != rawhide. The package versions are different.

On F-9, as I showed above, dbus-libs.i386 and dbus-libs.x86_64 cannot be
parralel installed. "Works on rawhide" is not a reason to close a bug for a
stable release.
Comment 3 David Zeuthen 2008-07-21 21:10:25 EDT
(In reply to comment #2)
> Reopening.
> 
> How can this be PEBCAK[sic]? F9 != rawhide. The package versions are different.
> 
> On F-9, as I showed above, dbus-libs.i386 and dbus-libs.x86_64 cannot be
> parralel installed. "Works on rawhide" is not a reason to close a bug for a
> stable release.

FWIW, this works just fine on my F9 box (and FWIW I had to grab dbus 1.2.1-2
from updates-testing, it's not in updates yet).

 # rpm -q dbus-libs dbus
 dbus-libs-1.2.1-2.fc9.x86_64
 dbus-libs-1.2.1-2.fc9.i386
 dbus-1.2.1-2.fc9.x86_64

 # cat /etc/fedora-release 
 Fedora release 9 (Sulphur)

just like predicted (D-Bus in rawhide and F-9 are pretty similar).

I specifically asked for more evidence than given before reopening the bug. Such
as pointing out what's wrong with the dbus packages. There's no evidence
whatsover this is a problem with the dbus packages. The bug may very well be
elsewhere; in the depsolver (try cleaning the yum cache and disable yum
plugins?) or in bogus dependencies in other packages. I'm sorry but it's not my
resposibility to do this detective work for you.

Please reopen only if you find a tangible problem (and ideally a solution in
patch(1) form) with the D-Bus packages. Thank you.

Note You need to log in before you can comment on or make changes to this bug.