Bug 456135 - qc timeout probing TEAC DV-28E-V CD/DVD drive on SATA/PATA bridge
qc timeout probing TEAC DV-28E-V CD/DVD drive on SATA/PATA bridge
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
high Severity high
: rc
: 5.6
Assigned To: David Milburn
Red Hat Kernel QE team
: OtherQA
Depends On:
Blocks: 499522 533192 483701 485920 525215
  Show dependency treegraph
 
Reported: 2008-07-21 13:19 EDT by Bryn M. Reeves
Modified: 2010-10-22 23:00 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 11:16:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2008-07-21 13:19:00 EDT
+++ This bug was initially created as a clone of Bug #453808 +++

Description of problem:
At boot and when attempting to access the CD/DVD drive the following messages
are logged:

2.6.18-85.el5:
    ata5: SATA max UDMA/133 cmd 0x10c0 ctl 0x10c8 bmdma 0x10e0 irq 90
    ata6: SATA max UDMA/133 cmd 0x10d0 ctl 0x10d8 bmdma 0x10e8 irq 90
    ata5.00: ATAPI: TEAC    DV-W28ECWS, G.S0, max MWDMA2
    ata5.00: applying bridge limits
    ata5.00: qc timeout (cmd 0xef)
    ata5.00: failed to set xfermode (err_mask=0x4)
    ata5: failed to recover some devices, retrying in 5 secs
    ata5: port is slow to respond, please be patient (Status 0xd0)
    ata5: device not ready (errno=-16), forcing hardreset
    ata5.00: revalidation failed (errno=-2)
    ata5: failed to recover some devices, retrying in 5 secs
    ata5.00: failed to set xfermode (err_mask=0x1)
    ata5.00: disabled

2.6.18-53.1.14.el5:
    ata5: SATA max UDMA/133 cmd 0x00000000000110c0 ctl 0x00000000000110ca bmdma 0x00
    000000000110e0 irq 90
    ata6: SATA max UDMA/133 cmd 0x00000000000110d0 ctl 0x00000000000110da bmdma 0x00
    000000000110e8 irq 90
    ata5.00: ATAPI, max MWDMA2
    ata5.00: applying bridge limits
    ata5.00: qc timeout (cmd 0xef)
    ata5.00: failed to set xfermode (err_mask=0x4)
    ata5: failed to recover some devices, retrying in 5 secs
    ata5: port is slow to respond, please be patient (Status 0xd0)
    ata5: device not ready (errno=-16), forcing hardreset
    ata5.00: failed to set xfermode (err_mask=0x1)
    ata5.00: limiting speed to MWDMA2:PIO3
    ata5: failed to recover some devices, retrying in 5 secs
    ata5.00: qc timeout (cmd 0xef)
    ata5.00: failed to set xfermode (err_mask=0x4)
    ata5.00: disabled

Drive identifies itself in /proc/scsi/scsi as:

   Host: scsi2 Channel: 00 Id: 00 Lun: 00
   Vendor: TEAC     Model: DV-28E-V         Rev: C.AB
   Type:   CD-ROM                           ANSI SCSI revision: 05


Version-Release number of selected component (if applicable):
2.6.18-53.1.14.el5, 2.6.18-85.el5xen, 2.6.18-85.el5

How reproducible:
100%

Steps to Reproduce:
1. Boot a system with the affected drive model attached to a SATA controller via
a PATA bridge
  
Actual results:
Above messages at boot time & as the system is running (presumably when
attempting to access the drive).

Expected results:
No messages at boot, drive works.

Additional info:
A similar problem was reported to the kernel.org bugzilla:

http://bugzilla.kernel.org/show_bug.cgi?id=10887

This involved the same drive model but attached directly to an IDE controller.
In that case the problem was avoided by increasing the retry count in
drivers/ide/ide-taskfile.c:wait_drive_not_busy() from 100 to 1000 (commit
f54feafa6d47d0aa1a96adefdc763b708b02f94f):

Author: Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
Date:   Fri Jun 20 20:53:33 2008 +0200

    ide: increase timeout in wait_drive_not_busy()
    
    Some ATAPI devices take longer than the current max timeout value to
    become ready (i.e. TEAC DV-W28ECW takes 6 ms) so increase the timeout
    value to 10 ms.
    
    This fixes kernel.org bugzilla bug #10887:
    http://bugzilla.kernel.org/show_bug.cgi?id=10887
    
    Reported-by: Masanari Iida <standby24x7@gmail.com>
    Signed-off-by: Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
Comment 3 RHEL Product and Program Management 2008-07-25 13:01:30 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 Ludek Smid 2008-07-25 17:55:14 EDT
Unfortunately the previous automated notification about the
non-inclusion of this request in Red Hat Enterprise Linux 5.3 used
the wrong text template. It should have read: this request has been
reviewed by Product Management and is not planned for inclusion
in the current minor release of Red Hat Enterprise Linux.

If you would like this request to be reviewed for the next minor
release, ask your support representative to set the next rhel-x.y
flag to "?" or raise an exception.
Comment 5 RHEL Product and Program Management 2009-02-16 10:09:42 EST
Updating PM score.
Comment 8 RHEL Product and Program Management 2009-10-01 12:16:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 Chris Ward 2009-10-14 06:36:31 EDT
@Bryn and customers encountering this issue,

We need to confirm that there is commitment to test 
for the resolution of this request during the RHEL 5.5 test
phase, if it is accepted into the release. 

Please post a confirmation before Oct 16th, 2009, 
including the contact information for testing engineers.
Comment 21 Issue Tracker 2009-11-20 16:56:27 EST
Event posted on 11-20-2009 04:56pm EST by jrfuller

I applied this patch to the kernel yesterday and rebooted. I have yet to
see the "kernel: hda: irq timeout: status=0xd0 { Busy }" error. I will
let it go over the weekend as it sometimes takes a day to show up. So far,
so good though.


This event sent from IssueTracker by jrfuller 
 issue 240512
Comment 22 David Milburn 2009-11-20 18:25:19 EST
Johnray, thanks for testing. Just to clarify, this patch is for the case
where the CD/DVD drive is controlled by libata. So on a failing system you
would see something like above in the description

    ata5.00: failed to set xfermode (err_mask=0x4)

And with this patch on bootup you should see something like 
(SET_XFERMODE skipped) for the device.
Comment 31 David Milburn 2010-05-07 11:16:05 EDT
Closing this until we can reproduce and verify a fix, please re-open if necessary.

Note You need to log in before you can comment on or make changes to this bug.