Bug 45632 - iptables-save: another incorrectly saved rule
iptables-save: another incorrectly saved rule
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: iptables (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
: 52251 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-24 08:06 EDT by Gerald Teschl
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-26 07:16:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iptables 1.2.2 patch for current Rawhide package (667 bytes, patch)
2001-06-26 07:15 EDT, Michael Schwendt
no flags Details | Diff
changed spec file (759 bytes, patch)
2001-06-26 07:16 EDT, Michael Schwendt
no flags Details | Diff

  None (edit)
Description Gerald Teschl 2001-06-24 08:06:34 EDT
The rule
	iptables -A INPUT -p tcp -j REJECT --reject-with tcp-reset
is saved as
	-A INPUT -p tcp -j REJECT --reject-with reject-with
rather than
	-A INPUT -p tcp -j REJECT --reject-with tcp-reset 

Please fix.
Comment 1 Michael Schwendt 2001-06-25 09:33:10 EDT
Wrong component: "ipchains". Please fix.
Comment 2 Michael Schwendt 2001-06-26 06:43:56 EDT
FWIW, from iptables 1.2.2's KNOWN_BUGS file:

Known bugs with the 2.4.0 kernel:

4) iptables-restore and -save still have problems. Sorry.
Comment 3 Mike A. Harris 2001-06-26 07:04:57 EDT
Wrong package owner.
Comment 4 Michael Schwendt 2001-06-26 07:15:32 EDT
Created attachment 21846 [details]
iptables 1.2.2 patch for current Rawhide package
Comment 5 Michael Schwendt 2001-06-26 07:16:25 EDT
Created attachment 21847 [details]
changed spec file
Comment 6 Bernhard Rosenkraenzer 2001-06-26 07:24:07 EDT
Thanks, added in 1.2.2-2
Comment 7 Bernhard Rosenkraenzer 2001-08-23 02:14:05 EDT
*** Bug 52251 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.