Bug 45633 - widgets have a large amount of padding and don't have the correct size
widgets have a large amount of padding and don't have the correct size
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tcltk (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
David Lawrence
http://sapphire.sourceforge.net/netcf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-24 10:03 EDT by Frank Hale
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-28 19:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
netcfg from 7.1 with locale of "ja_JP.eucJP" (same results with en and C) (4.12 KB, image/png)
2001-06-28 10:52 EDT, Eido Inoue
no flags Details

  None (edit)
Description Frank Hale 2001-06-24 10:03:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Tk widgets don't have the correct size, they have a large amount of padding
and some Tk apps such as the applets in the control-panel don't appear
correctly. I've tried many different installs of Redhat 7.1 and I always
get the same symptoms. The make xconfig tool in the kernel source easily
exceeds my 1024x760 screen res, the buttons are huge and have a large
amount of padding in them. Resizing the window doesn't correct the size of
the widgets. I've tried with many different window managers and the
symptoms still persist.

How reproducible:
Always

Steps to Reproduce:
1. Install fresh copy of Red hat Linux 7.1
2. Start X
3. Run any Tk app such as tkpasswd, make xconfig (kernel source), or
applets in the control-panel
	

Actual Results:  Tk widgets have incorrect size, buttons specifically have
large amounts of padding.

Expected Results:  Widgets should not have an unusually large amount of
padding in them. They should appear consistant, with other versions of Tk.

Additional info:

The version of tk is the one supplied by Red hat Linux 7.1. Symptoms appear
on fresh install with all default packages. No additional software was
installed on the machine affected. The video card is an ATI Expert 98, it
uses the Mach64 X Server and XFree86 4.0.3 is the version of X11.
Comment 1 Eido Inoue 2001-06-28 10:42:14 EDT
what's the locale you're running with? (do a "locale" command)

can you attach an screen shot showing the size of the window?

can't get the oversized windows to appear here.
Comment 2 Eido Inoue 2001-06-28 10:50:07 EDT
ok... I see the screenshot in the URL. However, I don't get those results. On my
7.1 box I see what's in the attachment.

Can you do a "locale" and tell me what fonts you're using?
Comment 3 Eido Inoue 2001-06-28 10:52:09 EDT
Created attachment 22067 [details]
netcfg from 7.1 with locale of "ja_JP.eucJP" (same results with en and C)
Comment 4 Frank Hale 2001-06-28 12:34:42 EDT
Yes I will do a locale and get its output. However I installed Red Hat Linux 
6.2 last night to see if the problem arose there. I had been using 6.2 for 
almost a year and didn't have the problem. Last nights install was also without 
problem. Netcfg appeared correctly, make xconfig in kernel source was correct 
and so was tkpasswd. I will reinstall 7.1 tonight and get the locale. However I 
have not changed it from the default it installed. I guess the locale would be 
whatever it is set to for the USA. Again I didn't change the font settings. I 
choose to install everything on the 7.1 install cd's. Whatever the defaults are 
is how my system is configured.
Comment 5 Frank Hale 2001-06-28 18:10:02 EDT
Here is the exact output of locale. The fonts I am using are the default fonts
installed when you select install everything during Red Hat Linux 7.1
installation. I have changed nothing, I just logged in. Problem persists. I will
make more screenshots and upload them.

Again the hardware is an ATI Xpert 98 video card, Intel PIII 500 mhz, BE6-II
motherboard. I recently installed Red Hat Linux 6.2 and I did not have the same
problems as with 7.1.   The version of X is XFree86 4.0.3.

LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE="en_US"
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=
Comment 6 Frank Hale 2001-06-28 19:00:42 EDT
Here are some links to more screenshots. These screenshots are of the various
apps which manifest the widget size problem. Note that the screen is 16 bits per
pixel and resolution is 1024x768. All fonts are default as per install.

http://sapphire.sourceforge.net/clock_cfg.jpg
http://sapphire.sourceforge.net/make_xconfig.jpg
http://sapphire.sourceforge.net/modem_cfg.jpg
http://sapphire.sourceforge.net/netcfg_1.jpg
http://sapphire.sourceforge.net/runlevel_cfg.jpg
http://sapphire.sourceforge.net/tkpasswd.jpg

I am beginning to think that this is not necessarily a tcl/tk problem and more
of an XFree86 4.0.3 or Font problem. Some pages under Netscape will have huge
fonts totally distorting the pages. Also KDE fonts are totally screwed up making
KDE useless, the fonts appear as a bunch of lines distorting windows and making
menu's and text unreadable. This is very interesting and happens on a fresh
install of Red Hat Linux 7.1 on my system.
Comment 7 Frank Hale 2001-06-30 16:33:56 EDT
Well I got a response from the seawolf-list and it suggested to that I add the 
line Display <width> <height> (where width and height are the size in 
millimeters) to my /etc/X11/XF86config-4 file in the monitor section. Once I 
did that the font problem disappeared. I suppose that Xconfigurator wasn't 
fully recognizing my KDS Avitron monitor. Although it did recognize the brand 
of monitor some of the settings I guess weren't recognized. While XFree86 3.3.6 
did correct recognize all settings under RHL 6.2, XFree86 4 would not under RHL 
7.1. I am not totally sure if this is a bug in Xconfigurator but adding that 
single line resolved all the font problems I was experiencing.

Note You need to log in before you can comment on or make changes to this bug.