This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 45634 - Fix alt key in slang/mutt
Fix alt key in slang/mutt
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: slang (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-24 10:15 EDT by Joe Orton
Modified: 2014-03-16 22:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-24 10:17:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
spec file patch (759 bytes, patch)
2001-06-24 10:16 EDT, Joe Orton
no flags Details | Diff
The slang patch (2.34 KB, patch)
2001-06-24 10:17 EDT, Joe Orton
no flags Details | Diff

  None (edit)
Description Joe Orton 2001-06-24 10:15:09 EDT
Description of Problem:
The 'Alt' key doesn't work in mutt.

How Reproducible:
Try 'alt-b' from a mailbox index: should prompt to Search with pattern "~b"

Actual Results:
mutt prints "Key is not bound."

Additional Information:
There is a patch included in mutt's contrib directory to fix this
behaviour: mutt's INSTALL file says

        There is a bug in most (if not all) S-Lang versions which
        prevents the Meta key from working with mutt.  A patch can
        be found in the file contrib/patch.slang-1.2.2.keypad.1 in
        this mutt distribution.

I've re-diffed this patch against 1.4.4 and will attach the patch and spec
file change. It works for me...
Comment 1 Joe Orton 2001-06-24 10:16:40 EDT
Created attachment 21646 [details]
spec file patch
Comment 2 Joe Orton 2001-06-24 10:17:40 EDT
Created attachment 21647 [details]
The slang patch
Comment 3 Bill Nottingham 2001-06-25 14:03:36 EDT
Added in 1.4.4-3, thanks.

Note You need to log in before you can comment on or make changes to this bug.