Bug 456381 - "Reply to List" is insensitive/Ctrl+L doesn't work
"Reply to List" is insensitive/Ctrl+L doesn't work
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-23 05:02 EDT by Nils Philippsen
Modified: 2008-08-01 09:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 09:41:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 545834 None None None Never

  None (edit)
Description Nils Philippsen 2008-07-23 05:02:06 EDT
Description of problem:
I can't use Message/Reply to List (or the Ctrl+L shortcut) with mailing list
mail (containing "List-*" headers), as the menu entry is insensitive/grayed out.

Version-Release number of selected component (if applicable):
evolution-2.22.3.1-1.fc9.x86_64
Comment 1 Milan Crha 2008-07-23 06:43:44 EDT
Thanks for reporting. Do you have a test mail for that? I think it doesn't work
when someone just CC the mailing list instead of using Reply to List, thus the
header is missing or other check fails there. We can see with the message itself.
Comment 2 Nils Philippsen 2008-07-23 08:51:09 EDT
I'll attach a mail to fedora-devel-announce@redhat.com which is sent directly to
the list (not Cc) and has all the headers needed AFAIK. I'll make the attachment
private, though.
Comment 4 Milan Crha 2008-07-23 10:45:08 EDT
Hmm, works for me. When I import your message to my local folder and hit Ctrl+L
the reply to fedora-devel-announce@redhat.com is opened. I tried this with
latest stable release, means 2.22.2 (from Help->About).

As I can see from the code, you should not have select more than one mail in a
view, if you do then the item is disabled. otherwise there should not be much
trouble with headers, they are there, somehow.
Comment 5 Nils Philippsen 2008-07-23 11:22:47 EDT
(In reply to comment #4)
> Hmm, works for me. When I import your message to my local folder and hit
> Ctrl+L the reply to fedora-devel-announce@redhat.com is opened. I tried this
> with latest stable release, means 2.22.2 (from Help->About).

Can you please verify this with evolution-2.22.3.1-1.fc9 (which is the latest
released update for Fedora 9)?

> As I can see from the code, you should not have select more than one mail in a
> view, if you do then the item is disabled.

I've only selected one message.
Comment 6 Milan Crha 2008-07-23 12:29:31 EDT
works fine with older evolution-2.22.2-2.fc9.x86_64
as well as with newer evolution-2.22.3.1-1.fc9.x86_64

one more time, I've stored your message in local store, where it came by
File->Import->Single file. Maybe it matters, maybe not.
Comment 7 Nils Philippsen 2008-07-23 12:47:39 EDT
It seems to make a difference where the message is stored:

- When imported into a local folder, "Reply to list" is sensitive for that message.
- When imported into mailboxes on cyrus-imapd servers (I've tried two different
servers), that menu entry is insensitive.
Comment 8 Milan Crha 2008-07-24 05:07:39 EDT
It can be because whole message wasn't downloaded from the server yet. (is it
possible?) The initial query from the IMAP server contains only a subset of
headers to minimize net traffic. Please look at the options and let me know what
you've there set. Follow Edit->Preferences->Mail Accounts->"choose your imap
account"->Edit->tab "IMAP headers". I have there chosen "Basic and Mailing List
headers (default)" and it works fine.
Comment 9 Nils Philippsen 2008-07-24 10:02:34 EDT
I'm very positive that the whole message has been downloaded because it was
displayed completely in the preview pane. I've also tried out all options
available in IMAP headers (and exited evolution, then evolution --force-shutdown
in between to be safe) which all had the same result -- a grayed out "Reply to
List" menu entry.
Comment 10 Milan Crha 2008-07-24 10:26:38 EDT
Once the message is downloaded to the summary, it is not re-downloaded again.
The summary files are stored in
~/.evolution/mail/imap/<your-account-id>/folders/INBOX/subfolders/... and so on
until you get to fedora-devel-announce folder.
As long as it's an imap, all information is stored there, so you can move the
folder somewhere else and let evo redownload the content. It will also recreate
the summary, with downloaded info as you require. Maybe the summary file is
somehow broken in that folder (any messages on the console?).

try to setup imap headers as described in the comment #8 to default value, then
close evo, evolution --force-shutdown, move the folder with summary somewhere
else and then start evolution. It will be slower because of downloading message
information and creating summary.

Did the rebuild make any difference?
Comment 11 Nils Philippsen 2008-07-24 12:39:27 EDT
It did make a difference for that folder. As I see this in all folders, would
you advise removing all my /.evolution/mail/imap/<your-account-id>/folders/
directories to enforce rebuilding the summaries?
Comment 12 Milan Crha 2008-07-24 13:15:01 EDT
Sure, you can do that. As long as it's an imap account, and most of the things
are stored on the server, then it should not hurt.

In case the summary rebuild helped and because Evolution 2.24 will have a
db-summary instead of the old one, then I guess we cannot do more here. That's
right the error report in this case should be better, and 2.22 contains some
mechanism to automaticly rebuild summaries in case of some inconsistency, but it
didn't help you, somehow. (That's true the rebuild had its bugs too, which has
been fixed in latest release of 2.22, but it was usually about message-list and
preview pane, where was shown different message in a preview and different one
selected in the message list.)
Comment 13 Nils Philippsen 2008-07-25 11:27:11 EDT
This has indeed fixed things with the mails on one server, but not on the other.
The IMAP server where evolution sets "Reply to List" insensitive is
cyrus-imapd-2.3.11-1.fc9.
Comment 14 Nils Philippsen 2008-07-25 11:28:30 EDT
NB: if I copy one ML mail from the non-working account into the working one,
"Reply to List" gets sensitive (on the copy of the mail, not the original).
Comment 15 Milan Crha 2008-07-31 12:53:45 EDT
Can you check if you've the option for the other account set as described in
comment #8, and if there is set to fetch mailing lists too? And if not, can you
help me to setup a cyrus-imapd on my machine to test it, please? I think I'm not
able to setup it in some easy way. Thanks.
Comment 16 Matthew Barnes 2008-07-31 16:47:47 EDT
Milan's on top of this.  Reassigning to him.
Comment 17 Nils Philippsen 2008-08-01 06:03:40 EDT
(In reply to comment #15)
> Can you check if you've the option for the other account set as described in
> comment #8, and if there is set to fetch mailing lists too?

Ahh that fixed it.

> And if not, can you
> help me to setup a cyrus-imapd on my machine to test it, please? I think I'm >
not able to setup it in some easy way. Thanks.

It's not that hard, but shouldn't be necessary.

One question though: doesn't evolution fetch the complete headers when
displaying the message? In that case, couldn't it evaluate the List-* headers?
Comment 18 Milan Crha 2008-08-01 09:41:35 EDT
I guess it's using information from summary, which contains the initial download
with the headers set in preferences, and it doesn't update this summary when
downloaded full message, thus summary still do not know that some mailing list
headers are present, even in the local cache, and UI, they are shown.

There will be done some changes in 2.24 regarding summaries. I asked upstream
developer and he said even new summary code can suffer such thing, thus I filled
an upstream bug [1] for you and closing this as that.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=545834

Note You need to log in before you can comment on or make changes to this bug.