Bug 456564 - build for firefox fails on s390 and s390x
build for firefox fails on s390 and s390x
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firefox (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Red Hat Gecko Maintainer
desktop-bugs@redhat.com
: Triaged
: 456567 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 13:56 EDT by Cameron Meadors
Modified: 2012-06-11 05:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 05:39:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cameron Meadors 2008-07-24 13:56:39 EDT
Error from s390:

doRpmCommand: rpm -qp --qf '%{NAME}\n%{ARCH}'
/mnt/redhat/brewroot/packages/firefox/3.0.1/3.el4/s390/firefox-3.0.1-3.el4.s390.rpm
doRpmCommand-result (0): firefox s390

TPSERROR: firefox-3.0.1-3.el4.s390.rpm is included in the file list but was not
built.
doRpmCommand: rpm -qp --qf '%{NAME}\n%{ARCH}'
/mnt/redhat/brewroot/packages/firefox/3.0.1/3.el4/s390/firefox-debuginfo-3.0.1-3.el4.s390.rpm
doRpmCommand-result (0): firefox-debuginfo s390

TPSERROR: firefox-debuginfo-3.0.1-3.el4.s390.rpm is included in the file list
but was not built.

ERROR: The number of packages built (0 + 0 multilib) does not match the number
of rpms in the file list (2)

Error from s390x:

doRpmCommand: rpm -qp --qf '%{NAME}\n%{ARCH}'
/mnt/redhat/brewroot/packages/firefox/3.0.1/3.el4/s390x/firefox-3.0.1-3.el4.s390x.rpm
doRpmCommand-result (0): firefox s390x

TPSERROR: firefox-3.0.1-3.el4.s390x.rpm is included in the file list but was not
built.
doRpmCommand: rpm -qp --qf '%{NAME}\n%{ARCH}'
/mnt/redhat/brewroot/packages/firefox/3.0.1/3.el4/s390x/firefox-debuginfo-3.0.1-3.el4.s390x.rpm
doRpmCommand-result (0): firefox-debuginfo s390x

TPSERROR: firefox-debuginfo-3.0.1-3.el4.s390x.rpm is included in the file list
but was not built.

ERROR: The number of packages built (0 + 0 multilib) does not match the number
of rpms in the file list (2)
Comment 1 Cameron Meadors 2008-07-24 14:03:04 EDT
Happens on i386 as well.  Here is the error from build log on i386.


c++ -o nsHTMLAreaElement.o -c -fvisibility=hidden -DMOZILLA_INTERNAL_API
-D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_COM_OBSOLETE
-D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES 
-DZLIB_INTERNAL -DOSTYPE=\"Linux2.6.9-67.0.20\" -DOSARCH=Linux -D_IMPL_NS_LAYOUT
 -I. -I. -I../../../../dist/include/xpcom -I../../../../dist/include/string
-I../../../../dist/include/gfx -I../../../../dist/include/thebes
-I../../../../dist/include/layout -I../../../../dist/include/widget
-I../../../../dist/include/dom -I../../../../dist/include/js
-I../../../../dist/include/locale -I../../../../dist/include/unicharutil
-I../../../../dist/include/webshell -I../../../../dist/include/uriloader
-I../../../../dist/include/htmlparser -I../../../../dist/include/necko
-I../../../../dist/include/view -I../../../../dist/include/pref
-I../../../../dist/include/docshell -I../../../../dist/include/xpconnect
-I../../../../dist/include/xuldoc -I../../../../dist/include/caps
-I../../../../dist/include/editor -I../../../../dist/include/imglib2
-I../../../../dist/include/mimetype -I../../../../dist/include/exthandler
-I../../../../dist/include/chardet -I../../../../dist/include/uconv
-I../../../../dist/include/intl -I../../../../dist/include/plugin
-I../../../../dist/include   -I../../../../dist/include/content
-I/usr/include/nspr4     -I../../../../dist/sdk/include -I./../../../base/src
-I./../../../events/src -I./../../../xbl/src -I./../../../../layout/style -I. 
-I/usr/X11R6/include   -fPIC  -I/usr/X11R6/include -fno-rtti -fno-exceptions
-Wall -Wconversion -Wpointer-arith -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-long-long
-pedantic -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED
-O2 -g -pipe -m32 -march=i386 -mtune=pentium4  -I/usr/X11R6/include
-DMOZILLA_CLIENT -include ../../../../mozilla-config.h
-Wp,-MD,.deps/nsHTMLAreaElement.pp nsHTMLAreaElement.cpp
./../../../base/src/nsGenericElement.h:414: warning: `virtual const
nsTextFragment* nsGenericElement::GetText()' was hidden
nsHTMLAnchorElement.cpp:94: warning:   by `virtual nsresult
nsHTMLAnchorElement::GetText(nsAString_internal&)'
gmake[7]: *** [nsHTMLBRElement.o] Segmentation fault
gmake[7]: *** Waiting for unfinished jobs....
nsGenericHTMLElement.cpp: In member function `virtual nsresult
nsGenericHTMLElement::SetAttr(PRInt32, nsIAtom*, nsIAtom*, const
nsAString_internal&, PRBool)':
nsGenericHTMLElement.cpp:1398: warning: 'change' might be used uninitialized in
this function
gmake[7]: Leaving directory
`/usr/src/redhat/BUILD/firefox-3.0.1/mozilla/content/html/content/src'
gmake[6]: *** [libs] Error 2
gmake[6]: Leaving directory
`/usr/src/redhat/BUILD/firefox-3.0.1/mozilla/content/html/content'
gmake[5]: *** [libs] Error 2
gmake[5]: Leaving directory
`/usr/src/redhat/BUILD/firefox-3.0.1/mozilla/content/html'
gmake[4]: *** [libs] Error 2
gmake[4]: Leaving directory `/usr/src/redhat/BUILD/firefox-3.0.1/mozilla/content'
gmake[3]: *** [libs_tier_gecko] Error 2
gmake[3]: Leaving directory `/usr/src/redhat/BUILD/firefox-3.0.1/mozilla'
gmake[2]: *** [tier_gecko] Error 2
gmake[2]: Leaving directory `/usr/src/redhat/BUILD/firefox-3.0.1/mozilla'
gmake[1]: *** [default] Error 2
gmake[1]: Leaving directory `/usr/src/redhat/BUILD/firefox-3.0.1/mozilla'
make: *** [build] Error 2
Comment 2 Cameron Meadors 2008-07-24 14:06:12 EDT
Sorry, different error on i386.  Ignore comment #1.  Error from s390 and s390x
are the same:

c++ -I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion
-Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-non-virtual-dtor -Wcast-align -Wno-long-long -pedantic -fno-strict-aliasing
-fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O2 -g -pipe -m31 -fPIC -shared
-Wl,-h,libxul.so -o libxul.so  nsStaticXULComponents.o nsUnicharUtils.o
nsCompressedCharMap.o nsBidiUtils.o nsRDFResource.o     -lpthread
-Wl,-rpath,/usr/lib/firefox-3.0.1  -Wl,-rpath-link,../../dist/bin 
-Wl,--whole-archive ../../embedding/browser/gtk/src/libgtkembedmoz.a
../../toolkit/xre/libxulapp_s.a  ../../staticlib/components/libxpconnect.a
../../staticlib/components/libnecko.a ../../staticlib/components/libuconv.a
../../staticlib/components/libi18n.a ../../staticlib/components/libchardet.a
../../staticlib/components/libjar50.a ../../staticlib/components/libpref.a
../../staticlib/components/libcaps.a ../../staticlib/components/libhtmlpars.a
../../staticlib/components/libimglib2.a ../../staticlib/components/libgklayout.a
../../staticlib/components/libdocshell.a
../../staticlib/components/libembedcomponents.a
../../staticlib/components/libwebbrwsr.a
../../staticlib/components/libnsappshell.a ../../staticlib/components/libtxmgr.a
../../staticlib/components/libchrome.a
../../staticlib/components/libcommandlines.a
../../staticlib/components/libtoolkitcomps.a
../../staticlib/components/libpipboot.a ../../staticlib/components/libpipnss.a
../../staticlib/components/libxmlextras.a
../../staticlib/components/libgkplugin.a ../../staticlib/components/libmozfind.a
../../staticlib/components/libappcomps.a
../../staticlib/components/libunixproxy.a
../../staticlib/components/libxpinstall.a ../../staticlib/components/libjsd.a
../../staticlib/components/libautoconfig.a ../../staticlib/components/libauth.a
../../staticlib/components/libcookie.a
../../staticlib/components/libpermissions.a
../../staticlib/components/libuniversalchardet.a
../../staticlib/components/libcomposer.a ../../staticlib/components/librdf.a
../../staticlib/components/libwindowds.a ../../staticlib/components/libintlapp.a
../../staticlib/components/libfileview.a
../../staticlib/components/libstoragecomps.a
../../staticlib/components/libplaces.a
../../staticlib/components/libtkautocomplete.a
../../staticlib/components/libsatchel.a ../../staticlib/components/libpippki.a
../../staticlib/components/libucvmath.a
../../staticlib/components/libwidget_gtk2.a
../../staticlib/components/libsystem-pref.a
../../staticlib/components/libgkgfxthebes.a ../../staticlib/components/liboji.a
../../staticlib/components/libaccessibility.a
../../staticlib/components/libremoteservice.a
../../staticlib/components/libspellchecker.a
../../staticlib/components/libzipwriter.a ../../staticlib/libxpcom_core.a
../../staticlib/libucvutil_s.a ../../staticlib/libgkgfx.a
../../staticlib/libgfxshared_s.a ../../staticlib/libmozreg_s.a
../../staticlib/libmorkreader_s.a ../../staticlib/libgtkxtbin.a
../../staticlib/libgfxpsshar.a ../../staticlib/libthebes.a
../../staticlib/libjsj.a  -Wl,--no-whole-archive -L../../dist/lib -lsqlite3
-L../../dist/bin -L../../dist/lib  -L../../dist/bin -L../../dist/lib -ljpeg 
-L../../modules/libimg/png -lmozpng -L../../dist/bin -lmozlcms -L../../dist/bin
-lmozjs -Wl,-rpath-link,/usr/lib -L/usr/lib -lssl3 -lsmime3 -lnss3 -lnssutil3
-lcrmf  -L../../modules/zlib/src -lmozz -L/usr/evolution28/lib -L/usr/X11R6/lib
-lpangocairo-1.0 -lcairo -lfreetype -lz -lfontconfig -lpng12 -lXrender -lX11
-lXext -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0  
../../gfx/cairo/cairo/src/libmozcairo.a
../../gfx/cairo/libpixman/src/libmozlibpixman.a   -L/usr/X11R6/lib -lXrender
-lfreetype -lfontconfig -L/usr/lib -lplds4 -lplc4 -lnspr4 -lpthread -ldl
-L/usr/X11R6/lib -lX11  -L/usr/X11R6/lib -lXft -lX11 -lfreetype -lXrender
-lfontconfig   -L/usr/evolution28/lib -L/usr/X11R6/lib -lgtk-x11-2.0 -latk-1.0
-lgdk-x11-2.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lpango-1.0 -lcairo
-lgmodule-2.0 -ldl -lfreetype -lz -lfontconfig -lpng12 -lXrender -lX11 -lXext
-lgobject-2.0 -lglib-2.0  -Wl,--rpath -Wl,/usr/evolution28/lib -lXt
-lgthread-2.0 -lfreetype -lz -ldl -lm     
collect2: ld terminated with signal 15 [Terminated]
gmake[4]: *** [libxul.so] Error 1
gmake[4]: Leaving directory
`/usr/src/redhat/BUILD/firefox-3.0.1/mozilla/toolkit/library'
gmake[3]: *** [libs_tier_toolkit] Error 2
gmake[3]: Leaving directory `/usr/src/redhat/BUILD/firefox-3.0.1/mozilla'
gmake[2]: *** [tier_toolkit] Error 2
gmake[2]: Leaving directory `/usr/src/redhat/BUILD/firefox-3.0.1/mozilla'
gmake[1]: *** [default] Error 2
gmake[1]: Leaving directory `/usr/src/redhat/BUILD/firefox-3.0.1/mozilla'
make: *** [build] Error 2
Comment 3 Martin Stransky 2010-03-17 03:38:49 EDT
A crash in ld...
Comment 4 Martin Stransky 2010-03-17 03:42:14 EDT
*** Bug 456567 has been marked as a duplicate of this bug. ***
Comment 5 Andreas Schwab 2010-11-04 10:54:11 EDT
It's not a crash, someone has killed it.
Comment 6 Martin Stransky 2012-06-11 05:39:28 EDT
RHEL4 is no longer supported so closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.