Bug 456589 - output from firefox printing to a postscript file is garbled
output from firefox printing to a postscript file is garbled
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ghostscript (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Tim Waugh
QE Internationalization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 16:10 EDT by Cameron Meadors
Modified: 2012-06-14 16:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 16:31:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample output from printing to a ps file (189.48 KB, application/postscript)
2008-07-24 16:26 EDT, Cameron Meadors
no flags Details

  None (edit)
Description Cameron Meadors 2008-07-24 16:10:19 EDT
When I print a webpage to a postscript file, it comes out garbled.  The links
are just blue lines and there are random characters throughout the document. 
Printing to a pdf file works fine.

Tested on i386 and x86_64 with firefox-3.0.1-1.el4 and firefox-3.0.1-3.el4
Comment 1 Cameron Meadors 2008-07-24 16:26:35 EDT
Created attachment 312595 [details]
sample output from printing to a ps file
Comment 2 Cameron Meadors 2008-07-24 16:27:48 EDT
so ggv on rhel 4.7 shows the attached file as garbled.  Evince on RHEL 5.2 shows
is clearly rendered.
Comment 3 Christopher Aillon 2008-07-24 16:35:28 EDT
So is the problem simply in ggv on RHEL4?  Does the file print to a printer okay?
Comment 5 Ben Levenson 2008-07-24 17:10:11 EDT
(In reply to comment #3)
> So is the problem simply in ggv on RHEL4?  Does the file print to a printer okay?

The hard copy looks fine (confirmed by gozen). So firefox doesn't appear to be
the culprit.

switching to ggv
Comment 6 Kristian Høgsberg 2008-09-30 12:10:36 EDT
I'll take a look, but it's more likely to be a ghostscript issue.
Comment 8 RHEL Product and Program Management 2008-10-31 12:46:04 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 ritz 2009-01-31 14:02:23 EST
seems to be an issue with gs, rather than ff itself.

# gs mozilla.ps
GNU Ghostscript 7.07 (2003-05-17)
Copyright (C) 2003 artofcode LLC, Benicia, CA.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Loading NimbusRomNo9L-Regu font from /usr/share/fonts/default/Type1/n021003l.pfb... 2469820 1099972 1642520 351150 0 done.
Using NimbusRomanNo9L-Regu font for NimbusRomNo9L-Regu.
Loading NimbusSanL-Regu font from /usr/share/fonts/default/Type1/n019003l.pfb... 2844780 1444610 1682712 365686 0 done.
Using NimbusSansL-Regu font for NimbusSanL-Regu.
Can't find (or can't open) font file /usr/share/ghostscript/Resource/Font/f-0-0.
Can't find (or can't open) font file f-0-0.
...
Substituting font Courier for f-0-0.

font loading issue. apparently, Courier is sans-serif, and ff uses serif by default for print.  Setting the font to sans-serif should fix part of this issue, provided liberation-fonts( for courier font) package is installed on system .
Comment 10 Issue Tracker 2009-02-01 12:16:12 EST
hmmm, this issue is only seen when printing to ps, and not to pdf.

-- ritz


This event sent from IssueTracker by rkhadgar 
 issue 251815
Comment 11 ritz 2009-02-02 09:40:41 EST
bingo - https://bugzilla.redhat.com/show_bug.cgi?id=120498

-- ritz
Comment 12 ritz 2009-02-05 12:26:03 EST
_TEST_ package can be downloaded from http://people.redhat.com/rkhadgar/work/bz456589/

-- ritz
Comment 15 RHEL Product and Program Management 2012-02-08 02:01:45 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Note You need to log in before you can comment on or make changes to this bug.