Bug 456662 - mod_auth_kerb does not build from SRPM
mod_auth_kerb does not build from SRPM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mod_auth_kerb (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Joe Orton
Boglarka Ronto
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-25 09:05 EDT by Vic
Modified: 2013-01-08 02:32 EST (History)
2 users (show)

See Also:
Fixed In Version: mod_auth_kerb-5.1-5.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:32:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vic 2008-07-25 09:05:35 EDT
Description of problem:
Rebuilding the mod_auth_kerb SRPM as a non-root user fails.


Version-Release number of selected component (if applicable):
5.1-3.el5 fails - 5.1-3 untested.


How reproducible:
Always


Steps to Reproduce:
1. Rebuild SRPM as a non-root user
2. Watch it fail
3.
  
Actual results:
Build failure with apxs not found


Expected results:
Correct build


Additional info:
apxs is needed by the build, and configure checks for it.

Unfortunately, httpd-devel puts apxs into /usr/sbin, which is not on path for
non-root users, so apxs is not found. The build bombs at that point.

As a workaround, /usr/sbin can be appended to PATH, which makes the build
succeed - but the fault should really be corrected with the call to configure in
the .spec file.
Comment 1 RHEL Product and Program Management 2012-04-19 07:48:49 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 8 errata-xmlrpc 2013-01-08 02:32:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0078.html

Note You need to log in before you can comment on or make changes to this bug.