Bug 456743 - After boot, ntp remains unsynchronized until restarted
After boot, ntp remains unsynchronized until restarted
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
: 460989 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-25 22:57 EDT by Naveed Hasan
Modified: 2008-09-04 04:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-08 04:48:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naveed Hasan 2008-07-25 22:57:07 EDT
On a cold boot of my desktop machine, the ntpd service remains unsynchronized
unless I manually restart the service at some later point. All configuration
files are unchanged from the defaults. Here's what I see in /var/log/messages -

Jul 25 17:59:12 ntpd[2159]: ntpd 4.2.4p4@1.1520-o Mon Apr  7 17:32:53 UTC 2008 (1)
Jul 25 17:59:12 ntpd[2160]: precision = 1.000 usec
Jul 25 17:59:12 ntpd[2160]: Listening on interface #0 wildcard, 0.0.0.0#123 Disabled
Jul 25 17:59:12 ntpd[2160]: Listening on interface #1 wildcard, ::#123 Disabled
Jul 25 17:59:12 ntpd[2160]: Listening on interface #2 lo, ::1#123 Enabled
Jul 25 17:59:12 ntpd[2160]: Listening on interface #3 lo, 127.0.0.1#123 Enabled
Jul 25 17:59:12 ntpd[2160]: kernel time sync status 0040
Jul 25 17:59:12 ntpd[2160]: frequency initialized -24.988 PPM from
/var/lib/ntp/drift
Jul 25 18:04:13 ntpd[2160]: Listening on interface #4 eth0,
fe80::211:11ff:fed2:8da5#123 Enabled
Jul 25 18:04:13 ntpd[2160]: Listening on interface #5 eth0, 192.168.1.100#123
Enabled
Jul 25 22:33:08 ntpd[2160]: ntpd exiting on signal 15
Jul 25 22:33:08 ntpd[32691]: ntpd 4.2.4p4@1.1520-o Mon Apr  7 17:32:53 UTC 2008 (1)
Jul 25 22:33:08 ntpd[32692]: precision = 1.000 usec
Jul 25 22:33:08 ntpd[32692]: Listening on interface #0 wildcard, 0.0.0.0#123
Disabled
Jul 25 22:33:08 ntpd[32692]: Listening on interface #1 wildcard, ::#123 Disabled
Jul 25 22:33:08 ntpd[32692]: Listening on interface #2 lo, ::1#123 Enabled
Jul 25 22:33:08 ntpd[32692]: Listening on interface #3 eth0,
fe80::211:11ff:fed2:8da5#123 Enabled
Jul 25 22:33:08 ntpd[32692]: Listening on interface #4 lo, 127.0.0.1#123 Enabled
Jul 25 22:33:08 ntpd[32692]: Listening on interface #5 eth0, 192.168.1.100#123
Enabled
Jul 25 22:33:08 ntpd[32692]: kernel time sync status 0040
Jul 25 22:33:08 ntpd[32692]: frequency initialized -24.988 PPM from
/var/lib/ntp/drift
Jul 25 22:33:14 ntpd_initres[2170]: parent died before we finished, exiting
Jul 25 22:37:25 ntpd[32692]: synchronized to 65.111.164.224, stratum 2
Jul 25 22:37:25 ntpd[32692]: kernel time sync status change 0001
Jul 25 22:46:08 ntpd[32692]: synchronized to 69.36.240.252, stratum 2

Note the long time of no synchronization after first startup, until I restart
the service at 22:33:08. Also, the ntpdate service is off and I am using
NetworkManager to manage my connectivity, if that makes any difference.

Thanks again for your help.
Comment 1 Miroslav Lichvar 2008-07-26 05:44:03 EDT
I managed to reproduce the problem and have a patch that should fix it. It's
caused by not reloading /etc/resolv.conf after NetworkManager update.

Thanks for the report.
Comment 2 Fedora Update System 2008-07-28 07:23:48 EDT
ntp-4.2.4p4-7.fc9 has been submitted as an update for Fedora 9
Comment 3 Fedora Update System 2008-07-30 16:07:50 EDT
ntp-4.2.4p4-7.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ntp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6851
Comment 4 Fedora Update System 2008-08-07 19:52:23 EDT
ntp-4.2.4p4-7.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Miroslav Lichvar 2008-09-04 04:14:33 EDT
*** Bug 460989 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.