Bug 456754 - smart runs out of memory during upgrades and leaves system in inconsistent state
smart runs out of memory during upgrades and leaves system in inconsistent state
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: smart (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-26 11:01 EDT by Andre Costa
Modified: 2008-12-21 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 17:04:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from last failed attempt on F9 (15.12 KB, text/plain)
2008-07-26 11:01 EDT, Andre Costa
no flags Details

  None (edit)
Description Andre Costa 2008-07-26 11:01:39 EDT
Description of problem:
Sometimes during an upgrade session smart consumes available memory very quickly
and aborts many of the installs operations, leading to duplicate packages and
sometimes even to RPM database corruption.

Version-Release number of selected component (if applicable):
smart-0.52-54.fc9.x86_64

How reproducible:
Sometimes. Maybe it's related to a specific package or a set of packages. It has
already happened to me twice (one with F8 and one with F9). On F8 RPM database
became corrupted, but I was able to recover it with rpm --rebuilddb.

Steps to Reproduce:
1. smart upgrade --update
2.
3.
  
Actual results:
"cannot allocate memory" errors, tipically during (before?) %post actions
execution (see attached session output). As a result, upgrade doesn't complete
for many of the packages, and old versions that should have been replaced remain
installed. Last time it happened, a simple "rpm -Uvh --force" on the downloaded
RPMs corrected the problem AFAICS.

Expected results:
Packages upgrade without problems.

Additional info:
System has 2GB RAM, there's no way smart could consume that much memory. Also,
When it happened with F8 I retried the command, and realized it consumes memory
*very* quickly (in a matter of seconds), there's some nasty memory leak going on.
Comment 1 Andre Costa 2008-07-26 11:01:39 EDT
Created attachment 312707 [details]
Output from last failed attempt on F9
Comment 2 Axel Thimm 2008-12-21 17:04:05 EST
These messages are not from smart, but from the packages' scripts.

I can't reproduce this locally. If you still have this issue, can you please check the memory consumption in another windows with top?

I'll close for now as WORKSFORME due to lack of reproducibility. Please reopen if you can still trigger this (but test with 1.1-58 first).

Note You need to log in before you can comment on or make changes to this bug.