Bug 456764 - redundant code in the package and spec file
redundant code in the package and spec file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: m2crypto (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-26 13:53 EDT by Andy Shevchenko
Modified: 2008-07-27 16:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-27 16:24:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Shevchenko 2008-07-26 13:53:01 EDT
Description of problem:

Preamble.
Attempt to use opensslconf-<arch>.h instead of opensslconf.h in the _ec.i 
bring to error in the swigging process, but that error is just hidden 
via -cpperraswarn. In result we have m2crypto w/o EC support.

Actually, m2crypto should not provide EC support at all like openssl does. 
Because you are using poor version of the OpenSSL w/o any EC support.
In result we have big inconvenience with programs which wish to use EC nodule 
of m2crypto.

Please, remove EC support in correct way.

Version-Release number of selected component (if applicable):
All in Fedora.

P.S. Also, please, look to additional info at
http://fcp.surfsite.org/modules/newbb/viewtopic.php?viewmode=flat&order=ASC&topic_id=37777&forum=11
Comment 1 Miloslav Trmač 2008-07-27 16:24:08 EDT
Thanks for your report.

The header file modifications performed in the spec file are, except for the
warning, completely transparent to the build process.  If openssl were built
without EC but not modified to use a separate header, the M2Crypto build (code
and available symbols) would be exactly the same as it is with the current
Fedora packages.

If the application requires EC support, it cannot be used with the openssl - and
M2Crypto - shipped in Fedora.  If the application could run without EC support,
and crashes with the Fedora M2Crypto, it is not detecting missing EC correctly
(using M2Crypto.m2.OPENSSL_NO_EC).

Note You need to log in before you can comment on or make changes to this bug.