Bug 456803 - python failure in yumex
python failure in yumex
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-27 08:22 EDT by Herbert Carl Meyer
Modified: 2008-08-11 14:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-11 14:21:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Herbert Carl Meyer 2008-07-27 08:22:59 EDT
Description of problem:
yumex will not start

Version-Release number of selected component (if applicable):
yumex-2.0.4-1.fc9.noarch

How reproducible:
100%

Steps to Reproduce:
1.open a terminal
2.start yumex from command line
  
Actual results:

[root@evilgnome ~]# yumex &
[1] 3927
[root@evilgnome ~]# Invalid MIT-MAGIC-COOKIE-1 keyTraceback (most recent call last):
  File "/usr/share/yumex/yumex.py", line 29, in <module>
    import gtk,gobject
  File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 79, in
<module>
    _init()
  File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 67, in _init
    _gtk.init_check()
RuntimeError: could not open display

[1]+  Exit 1                  yumex
[root@evilgnome ~]# 


Expected results:

yumex starts.

Additional info:
Comment 1 Timothy Davis 2008-07-28 00:49:33 EDT
yumex runs from command line "python /usr/share/yumex/yumex.py" but only as
normal user, when run as root the same error messages.
Comment 2 Timothy Davis 2008-07-28 05:01:20 EDT
Created symlink from /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so to
/usr/lib/ and reran yumex from menu. Successfully uninstalled kdegames.
Comment 3 Tim Lauridsen 2008-08-05 08:47:18 EDT
Can't reproduce this error.
try running 'xhost +' before running 'yumex &'
Comment 4 Timothy Davis 2008-08-09 23:56:10 EDT
After updating to yumex-2.0.4 and removing the symlink to libcanberra-gtk-modules it is working.

Note You need to log in before you can comment on or make changes to this bug.