Bug 456805 - Freeciv fails to start/ connect to server
Freeciv fails to start/ connect to server
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: freeciv (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
: 460617 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-27 10:26 EDT by Douglas Furlong
Modified: 2008-09-18 17:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 19:26:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bugreport (244.40 KB, text/plain)
2008-07-27 10:26 EDT, Douglas Furlong
no flags Details
debug output -d 3 (168.94 KB, application/octet-stream)
2008-07-27 10:27 EDT, Douglas Furlong
no flags Details

  None (edit)
Description Douglas Furlong 2008-07-27 10:26:46 EDT
Description of problem:

When attempting to load a game, start a new game or start a cenario, civclient
crashes.

At the bottom of the screen some of the time you'll see "starting server" some
of the time, just before crashing, but not all the time.

Additionally starting the server seporately, and then trying to connect to it,
results in the client crashing.

Server registers the connection, and then says the client has disconnected.

Version-Release number of selected component (if applicable):
Name        : freeciv                      Relocations: (not relocatable)
Version     : 2.1.5                             Vendor: Fedora Project
Release     : 1.fc9                         Build Date: Fri 20 Jun 2008 01:43:54
AM BST


How reproducible:

97%
Every so often it works.

Steps to Reproduce:
1. Start Civclient
2. Attempt to start a cenario/ load a game/ connect to server.
3.
  
Actual results:

Client crashes.

Expected results:

Client shouldn't crash.

Additional info:

I've tried this on two different systems, with the same results.
Comment 1 Douglas Furlong 2008-07-27 10:26:46 EDT
Created attachment 312728 [details]
bugreport
Comment 2 Douglas Furlong 2008-07-27 10:27:35 EDT
Created attachment 312729 [details]
debug output -d 3
Comment 3 Douglas Furlong 2008-08-14 05:47:28 EDT
Heyah

Is there any thing that I can do to help resolve this bug?
Comment 4 Brian Pepple 2008-08-29 00:34:54 EDT
*** Bug 460617 has been marked as a duplicate of this bug. ***
Comment 5 Pramod Dematagoda 2008-08-29 04:23:05 EDT
I just compiled and ran version 2.1.6 of FreeCiv and it works perfectly. I think this issue is fixed there.
Comment 6 Fedora Update System 2008-09-01 20:35:33 EDT
freeciv-2.1.6-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/freeciv-2.1.6-1.fc9
Comment 7 Fedora Update System 2008-09-10 03:14:39 EDT
freeciv-2.1.6-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freeciv'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7517
Comment 8 Fedora Update System 2008-09-16 19:26:12 EDT
freeciv-2.1.6-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Douglas Furlong 2008-09-18 17:18:18 EDT
All appears to be working for me now that I've installed this update.

Note You need to log in before you can comment on or make changes to this bug.