Bug 456837 - wlan unstable with rtl8187 and wpa_supplicant
wlan unstable with rtl8187 and wpa_supplicant
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-27 19:55 EDT by Stefan Jensen
Modified: 2009-01-27 09:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 11:48:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Jensen 2008-07-27 19:55:41 EDT
Description of problem:

wpa_supplicant often fails to configure wlan interface on boot.


Version-Release number of selected component (if applicable):

kernel-2.6.25.11-60.fc8
kernel-headers-2.6.25.11-60.fc8
kernel-devel-2.6.25.11-60.fc8
wpa_supplicant-0.5.10-5.fc8

How reproducible:

Always

Steps to Reproduce:

boot with configured wlan0 and wpa_supplicant
  
Actual results:

no connection to WPA Accesspoint on boot

Expected results:

connection to AP on boot

Additional info:

$ lsusb | grep -i realtek

Bus 001 Device 002: ID 0bda:8187 Realtek Semiconductor Corp.

$ lsmod | grep rtl

rtl8187                40001  0 
mac80211              177205  1 rtl8187
eeprom_93cx6            6081  1 rtl8187
cfg80211               25929  2 rtl8187,mac80211

$modinfo rtl8187

filename:       /lib/modules/2.6.25.11-60.fc8/kernel/drivers/net/wireless/rtl8187.ko
license:        GPL
description:    RTL8187/RTL8187B USB wireless driver
author:         Andrea Merello <andreamrl@tiscali.it>
author:         Michael Wu <flamingice@sourmilk.net>
srcversion:     EA5E4DABFA4E61087A948DC
[...]

$uname -a

Linux localhost.localdomain 2.6.25.11-60.fc8 #1 SMP Mon Jul 21 02:06:29 EDT 2008
i686 i686 i386 GNU/Linux

$wpa_supplicant -v

wpa_supplicant v0.5.10
Copyright (c) 2003-2008, Jouni Malinen <j@w1.fi> and contributors

$ wpa_supplicant -qq -c /etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dwext -f -t

ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCGIWSCAN]: Resource temporarily unavailable

==> messages <==
Jul 28 01:40:18 hurricane kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jul 28 01:40:20 hurricane kernel: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Comment 1 Hin-Tak Leung 2008-10-31 19:38:57 EDT
I think we fixed this in 2.6.26.x/2.6.27.x-ish. Is this still an issue?
Comment 2 Stefan Jensen 2008-10-31 20:24:53 EDT
Yes, it is partly an issue. The connection can now successful establish every boot, but always with this error:

ioctl[SIOCSIWAUTH]: Operation not supported WEXT auth param 4 value 0x0 -

and the link quality is pretty low, even if i place the AP next beside me.
(but this can be a issue with my card, maybe...)

$ iwconfig wlan0

[...]
 Link Quality=16/100  Signal level:65/65 
[...]

I'm using now:

$ modinfo rtl8187

filename:       /lib/modules/2.6.26.6-49.fc8/kernel/drivers/net/wireless/rtl8187.ko
license:        GPL
description:    RTL8187/RTL8187B USB wireless driver
author:         Andrea Merello <andreamrl@tiscali.it>
author:         Michael Wu <flamingice@sourmilk.net>
srcversion:     E9AACD354F4F5132591DD84
[...]
depends:        mac80211,eeprom_93cx6,cfg80211
vermagic:       2.6.26.6-49.fc8 SMP mod_unload 686 4KSTACKS 

$ uname -a
Linux localhost.localdomain 2.6.26.6-49.fc8 #1 SMP Fri Oct 17 15:59:36 EDT 2008 i686 i686 i386 GNU/Linux

best regards
Comment 3 Hin-Tak Leung 2008-10-31 20:59:56 EDT
Hmm, the WEXT message is due to some mismatch between kernel and user tools,
how's that possible? Do you have a self-install wpa_supplicant, etc?

The link-level, etc is being improved at the moment...
Comment 4 Stefan Jensen 2008-11-01 09:05:20 EDT
Mmh, i'm using all the stock rpm's, that comes with Fedora.

wpa_supplicant-0.5.10-6.fc8
wireless-tools-29-0.2.pre22.fc8

I played around a little with wpa_supplicant and found, that this errror disappears, when i start wpa_supplicant with the "-w" option (wait for interface to be added, if needed.).

So there might be some timing issue elsewhere? Anyway, i think this may not related to the kernel driver?

thanks
Comment 5 Hin-Tak Leung 2008-11-01 13:31:17 EDT
NetworkManager is responsible for launching wpa_supplicant on demand, I think. The link quality, etc are being improved as we speak (i.e. my laptop has some prototype patches I am testing from somebody else) - and some of fc9 kernels are gradually having them, so it will gradually filter down. OTOH, there are a lot of wireless-related improvements, so one of these day you should upgrade to fc9. (and in a few weeks, fc10).
Comment 6 Stefan Jensen 2008-11-03 11:47:24 EST
I'm not using NetworkManager in F8, to many problems. ;-) Therefor i am using wpa_supplicant without the dbus interace (-u). At the moment i'm still stick to F8 and wait for F10.

I'm pretty fine with this "solution" right now and i can live with this low Link level thing for now. So works for me.

Thanks
Comment 7 Stefan Jensen 2009-01-26 08:31:30 EST
I switched now to F10. The new module is working fine (with both NM or standalone wpa_supplicant), but still with very low link quality. I have to use it now on a "real" link and i'm not able to get much traffic over the air. Please can you provide one of these "prototype patches"? I'm willing to testing and/or proofing.

Thanks!
Comment 8 Hin-Tak Leung 2009-01-27 09:12:00 EST
Download a current compat-wireless tar ball and give it a spin. I think you will find it work even better than what f10 gives you.
http://linuxwireless.org/en/users/Download

Any issues with compat-wireless, write to the linux-wireless mailing list and cc the 3 of us. (me, Larry and Herton, the current maintainers of the rtl8187 driver; the e-mail addresses are in the source code...).

Note You need to log in before you can comment on or make changes to this bug.