Bug 45686 - Anaconda exits with internal error after choosing partitionless install
Anaconda exits with internal error after choosing partitionless install
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 46485 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-24 15:37 EDT by Steve
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-06 00:41:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback, Local variables, and ToDo list saved to floppy (10.46 KB, text/plain)
2001-06-24 15:39 EDT, Steve
no flags Details

  None (edit)
Description Steve 2001-06-24 15:37:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win98; U)

Description of problem:
Anaconda exits with internal error (system error 22) after choosing partitionless install on extended Fat32 partition under Win98.

How reproducible:
Always

Steps to Reproduce:
1. Choose custom install, either graphical or text
2. Run Disk Druid
3. Choose extended partition (4 GB on a 12 GB drive) - drive D: in Windows 98 - and enter / as mount point
4. Click OK on warning about about inability to use other partitions and speed penalty
5. Click Next

Actual Results:  Received system error 22 - invalid argument.
Saved debug info to floppy, included as attachment.
Installation aborted.

Expected Results:  Installation should have continued.

Additional info:
See attachment for full info.  Traceback included here:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 391, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 879, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 500, in nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 610, in setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/rootpartition_gui.py", line 189, in getScreen
    avail = apply(isys.spaceAvailable, rootdev)
  File "/mnt/redhat/test/qa0408.4/i386/RedHat/instimage/usr/lib/anaconda/isys.py", line 19, in spaceAvailable
    mount(device, "/mnt/space", fstype = fsystem)
  File "/mnt/redhat/test/qa0408.4/i386/RedHat/instimage/usr/lib/anaconda/isys.py", line 120, in mount
    rc = _isys.mount(fstype, device, location, readOnly)
SystemError: (22, 'Invalid argument')
Comment 1 Steve 2001-06-24 15:39:19 EDT
Created attachment 21668 [details]
Traceback, Local variables, and ToDo list saved to floppy
Comment 2 Brent Fox 2001-06-25 10:26:12 EDT
Did you assign a mount point to a FAT partition?
Comment 3 Steve 2001-06-25 22:41:49 EDT
Yes, I assigned "/" to the FAT32 partition.  I understand that is the way to set up a "partitionless" install.  This is an extended partition - C: is 
the primary partition, D: (where I wanted to install Linux) is an extended partition with 2 GB free space.  They both reside on a single 12 GB 
drive.
Comment 4 Brent Fox 2001-06-26 14:46:43 EDT
So D: already existed and was formatted as FAT32 before you began the install?
Comment 5 Steve 2001-06-26 23:34:10 EDT
Correct.  C: (8 GB) and D: (4 GB) both exist and are formatted FAT32.  I use D: as backup storage for critical Win98 files, and I don't really 
want to blow them away, thus the choice for a partitionless install.
Comment 6 Brent Fox 2001-06-27 13:55:09 EDT
Ok, how much swap space did you allow?
Comment 7 Steve 2001-06-27 22:10:39 EDT
None.  The message indicated that I couldn't use any other partitions, so I thought everything would just go under "/".  Not true?  I need to 
specify another filesystem for swap?  How would I do that?
Comment 8 Brent Fox 2001-06-29 19:33:55 EDT
On the screen after Disk Druid, it should have asked you how much swap space you
want.  On a partitionless install, swap can't be on another filesystem, so it is
a swap file instead.  I think that it defaults to 32 MB of swap...which probably
isn't enough.  I think the default may have been set too low.  Can you try again
and look at the screen after Disk Druid and set the swap space to twice as much
space as RAM your machine has?  For example, if your machine has 64MB of RAM,
try making 128MB of swap.  Does that help?
Comment 9 Brent Fox 2001-06-29 19:35:01 EDT
*** Bug 46485 has been marked as a duplicate of this bug. ***
Comment 10 Steve 2001-07-01 17:20:51 EDT
As soon as I click on "OK" (I think that's what the button says) and exit Disk Druid, I get the error.  I never reach the point of specifying the swap file size.
Comment 11 Brent Fox 2001-07-06 00:41:14 EDT
I don't really know why this is happening.  It always seems like some people
have problems with partitionless installs no matter what we do.  Partitionless
installs work for me on my test machine, so I can't really figure out what is
wrong.  The only time I've been able to reproduce this kind of thing is if the
DOS partition is not formatted or did not previously exist.  But since you have
data on your D: drive, this is obviously not the case for you.  Partitionless
installs just seem to be a little unreliable.

Note You need to log in before you can comment on or make changes to this bug.