This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 456930 - can not run dtach from cron
can not run dtach from cron
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dtach (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Lon Hohberger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-28 13:58 EDT by Doncho N. Gunchev
Modified: 2008-07-29 09:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-29 09:59:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 438335 None None None Never

  None (edit)
Description Doncho N. Gunchev 2008-07-28 13:58:33 EDT
Description of problem:
Running for example
/usr/bin/dtach -n /tmp/sleep.sock bash -c "sleep 10"
from a cron script results in:
tcgetattr: Inappropriate ioctl for device

Version-Release number of selected component (if applicable):
dtach-0.7-3

How reproducible:
always

Steps to Reproduce:
1. dtach -n test.sock sleep 10 < /dev/null
  
Actual results:
dtach: tcgetattr: Inappropriate ioctl for device

Additional info:
I have the same problem with FC8 and RHEL 5 (RackSpace). Updating to 0.8 helped.
I used the info from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=438335
Comment 1 Lon Hohberger 2008-07-28 16:07:40 EDT
I have pushed 0.8-1 to rawhide.
Comment 2 Lon Hohberger 2008-07-28 16:07:56 EDT
Or rather, built it for rawhide.  I will backport at a later time.
Comment 4 Lon Hohberger 2008-07-29 09:59:55 EDT
Since this was filed as a low priority bug, I'm closing this.  0.8-1 is
available in rawhide.


Note You need to log in before you can comment on or make changes to this bug.