Bug 456957 - Cleanup the schema from cruft and JBoss migration
Cleanup the schema from cruft and JBoss migration
Status: CLOSED WONTFIX
Product: JBoss Customer Support Portal
Classification: Retired
Component: Performance (Show other bugs)
1.3.8
All All
medium Severity low
: ---
: ---
Assigned To: JBoss CSP Bug Watch List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-28 17:44 EDT by Mike Amburn
Modified: 2011-01-31 12:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-31 12:39:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Amburn 2008-07-28 17:44:20 EDT
The "portal" schema is full of cruft left from years of Issue-Tracker
development and the JBoss migration. The extra data affects backups, replication
for GSS, and hampers development.
Comment 1 Mike Amburn 2008-07-28 17:45:27 EDT
Structural Changes
  * Tables
    o Drop
      1. accounts - used in JBoss migration, no longer needed
      2. knowledge_dashboard - used in JBoss Network, deprecated
      3. sessions - never intended to go to production
      4. snapshot_metadata
      5. ticket_grouping
      6. ticket_link_groups
      7. transaction_events 
    o Rename
      1. announce_permissions -> announcements_groups
      2. group_product_assignment -> group_product_escalation 

  * Columns
    o Drop
      1. ticket_fields.field_id - duplicate of id 
Comment 2 Mike Amburn 2008-07-28 17:45:33 EDT
Null Value Contraints
  * ADD
     1. announcements.posted
     2. announcements.is_global 
Comment 3 Mike Amburn 2008-07-28 17:46:17 EDT
Data Types
  * ALTER
    1. event_modifications.modified -> change to date type 
Comment 4 David Spalding 2011-01-31 12:39:32 EST
Bugs are no longer tracked under this classification. CSP is now monitored in 
Other | Customer Portal | Integrated app: JBoss CSP. 

Please refile any current defect records or RFEs under the current 
classification.
Comment 5 David Spalding 2011-01-31 12:47:31 EST
Bugs are no longer tracked under this classification. CSP is now monitored in 
Other | Customer Portal | Integrated app: JBoss CSP. 

Please refile any current defect records or RFEs under the current 
classification.

Note You need to log in before you can comment on or make changes to this bug.