Bug 457050 - Installing to '/' as ext4dev - kernel BUG at fs/ext4/mballoc.c:3941!
Installing to '/' as ext4dev - kernel BUG at fs/ext4/mballoc.c:3941!
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-29 09:39 EDT by James Laska
Modified: 2013-09-02 02:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 17:01:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel error (7.88 KB, text/plain)
2008-07-29 09:39 EDT, James Laska
no flags Details
Anaconda partitioning screenshot (64.88 KB, image/png)
2008-07-29 10:54 EDT, James Laska
no flags Details
anaconda-ppc-logs.tgz (13.25 KB, application/x-compressed-tar)
2008-07-29 11:19 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-07-29 09:39:49 EDT
Description of problem:

Installing rawhide (2008-08-29) stalls during package install.  Inspecting the
console shows a kernel error.

Version-Release number of selected component (if applicable):

* anaconda-11.4.1.20-1
* kernel-2.6.27-0.186.rc8.git15.fc10
* e2fsprogs-1.41.0-1.fc10

How reproducible:
100%

Steps to Reproduce:
1. Boot rawhide installer with 'ext4' command-line arg
2. Select autopart and review partitions
3. Change '/' to a ext4dev
  
Actual results:

Package install hangs during installation of glibc-common package and a kernel
bug is displayed on the root console (see attachment)

Expected results:

Installation completes without error

Additional info:
Comment 1 James Laska 2008-07-29 09:39:49 EDT
Created attachment 312872 [details]
kernel error
Comment 2 Eric Sandeen 2008-07-29 09:55:35 EDT
EXT3-fs: sda2: couldn't mount because of unsupported optional features (40).

Which filesystem was sda2?

EXT4-fs warning (device dm-0): ext4_fill_super: extents feature not enabled on
this filesystem, use tune2fs.

and was this the root fs?

Thanks,
-Eric
Comment 3 James Laska 2008-07-29 10:54:15 EDT
Created attachment 312883 [details]
Anaconda partitioning screenshot

> Which filesystem was sda2?

sda2 should be a ext3 /boot

> and was this the root fs?

'/' is a logical volume
Comment 4 James Laska 2008-07-29 11:19:11 EDT
Created attachment 312893 [details]
anaconda-ppc-logs.tgz

The log files on the install prior to the failure.

$ tar -ztvf anaconda-ppc-logs.tgz 
-rw-r--r-- root/root	 70681 2008-07-29 11:13 tmp/anaconda.log
-rw-r--r-- root/root	 30485 2008-07-29 11:09 tmp/syslog
-rw-r--r-- root/root	    38 2008-07-29 11:09 tmp/lvmout
-rw-r--r-- root/root	   144 2008-07-29 11:01 tmp/netinfo
-rwxr-xr-x root/root	   852 2008-07-29 11:07 tmp/vncserver.log
-rw-r--r-- root/root	   746 2008-07-29 04:49 tmp/.treeinfo
-rw-r--r-- root/root	   772 2008-07-29 11:13 mnt/sysimage/etc/fstab
Comment 5 Bug Zapper 2008-11-25 21:37:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Robin Laing 2009-03-10 01:23:52 EDT
I don't know if this is relevent but in my /var/log/messages I am getting many messages like this.



Mar  2 00:42:42 eagle2 kernel: EXT4-fs: mballoc: 0 blocks 0 reqs (0 success)                                                                  
Mar  2 00:42:42 eagle2 kernel: EXT4-fs: mballoc: 0 extents scanned, 0 goal hits, 0 2^N hits, 0 breaks, 0 lost                                 
Mar  2 00:42:42 eagle2 kernel: EXT4-fs: mballoc: 0 generated and it took 0                                                                    
Mar  2 00:42:42 eagle2 kernel: EXT4-fs: mballoc: 0 preallocated, 0 discarded                                                                  
Mar  2 00:42:44 eagle2 kernel: EXT4-fs: mballoc: 967814 blocks 14514 reqs (5212 success)                                                      
Mar  2 00:42:44 eagle2 kernel: EXT4-fs: mballoc: 10041 extents scanned, 725 goal hits, 9545 2^N hits, 0 breaks, 0 lost                        
Mar  2 00:42:44 eagle2 kernel: EXT4-fs: mballoc: 1651 generated and it took 137632015                                                         
Mar  2 00:42:44 eagle2 kernel: EXT4-fs: mballoc: 475175 preallocated, 238094 discarded
Mar  8 01:45:10 eagle2 kernel: EXT4-fs: mballoc: 2719 blocks 194 reqs (158 success)
Mar  8 01:45:10 eagle2 kernel: EXT4-fs: mballoc: 50 extents scanned, 12 goal hits, 33 2^N hits, 0 breaks, 0 lost
Mar  8 01:45:10 eagle2 kernel: EXT4-fs: mballoc: 33 generated and it took 659365
Mar  8 01:45:10 eagle2 kernel: EXT4-fs: mballoc: 17218 preallocated, 16158 discarded


Mar  8 04:52:32 eagle2 kernel: EXT4-fs: mballoc: 0 blocks 0 reqs (0 success)                                                                    
Mar  8 04:52:32 eagle2 kernel: EXT4-fs: mballoc: 0 extents scanned, 0 goal hits, 0 2^N hits, 0 breaks, 0 lost                                   
Mar  8 04:52:32 eagle2 kernel: EXT4-fs: mballoc: 0 generated and it took 0                                                                      
Mar  8 04:52:32 eagle2 kernel: EXT4-fs: mballoc: 0 preallocated, 0 discarded                                                                    
Mar  8 04:52:35 eagle2 kernel: EXT4-fs: mballoc: 0 blocks 0 reqs (0 success)                                                                    
Mar  8 04:52:35 eagle2 kernel: EXT4-fs: mballoc: 0 extents scanned, 0 goal hits, 0 2^N hits, 0 breaks, 0 lost                                   
Mar  8 04:52:35 eagle2 kernel: EXT4-fs: mballoc: 0 generated and it took 0                                                                      
Mar  8 04:52:35 eagle2 kernel: EXT4-fs: mballoc: 0 preallocated, 0 discarded 





This is on F10, i386, fully updated system.

SATA drives.  Motherboard SATA controller with updated bios and SATA drivers.
Comment 7 Chuck Ebbert 2009-03-28 09:26:55 EDT
(In reply to comment #6)
> I don't know if this is relevent but in my /var/log/messages I am getting many
> messages like this.

Are you running the debug kernel?
Comment 8 Eric Sandeen 2009-06-30 17:01:22 EDT
A lot of changes have happened since .27, and apparently this is fixed, given that we shipped ext4 as default fs in F11 :)

Note You need to log in before you can comment on or make changes to this bug.