Bug 4571 - DiskDruid damages partition table
DiskDruid damages partition table
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-17 09:50 EDT by frode.nilsen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-20 02:28:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description frode.nilsen 1999-08-17 09:50:09 EDT
Had a hard drive (second drive) with no primary partition,
although there was 0.4Mb free in this area.
There where two extended partitions with one 50Mb for windows
swap and 300Mb for dos backup, wanted to use the remaining
~60Mb for Linux swap.

DiskDruid where told to create a new partition with the size
of free space.

RESULT: DiskDruid allocated a partition starting in the
primary partition part, thereby overwriting data in existing
partitions.

Lucky me, I stopped the installation and checked the
partition tables before any formating was done.

Fixed the problem by deleting this erroneus partition with
DOS fdisk, created the partition with Partition Magic (that
reported the problem) and changed the type with Linux fdisk.

For information: OS/2 fdisk has this same kind of problem.
Due to this small free space in the primary partition part.
Comment 1 Jay Turner 2000-02-11 10:55:59 EST
This is the programmer behavior of Disk Druid.  Users that want to control where
partitions reside on a drive are encouraged to use fdisk.
Comment 2 frode.nilsen 2001-08-20 02:28:05 EDT
I didn't know it was the intended behaviour of DiskDruid to thrash other 
partitions content, if so, please show that in bold face on your distribution 
documentation!!!
Please have someone that understand partitions tables to review this 
bug. (I mailed jturner about his comment, but he didn't seem to 
understand the problem).
Comment 3 Matt Wilson 2001-08-20 09:39:58 EDT
What installation option did you use?  Did you elect to use automatic
partitioning at all?  This should all be resolved in the new code in the next
version.  You can preview it in the Red Hat Linux Roswell beta at
ftp://ftp.redhat.com/pub/redhat/linux/beta/roswell

Note You need to log in before you can comment on or make changes to this bug.