Bug 457186 - Update to grip 3.3.1
Update to grip 3.3.1
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: grip (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
http://sourceforge.net/project/showfi...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 01:49 EDT by Stefan Becker
Modified: 2008-09-24 20:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 20:12:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Corrected "execute command after encode" patch (2.51 KB, patch)
2008-08-11 05:22 EDT, Stefan Becker
no flags Details | Diff

  None (edit)
Description Stefan Becker 2008-07-30 01:49:20 EDT
Please consider to upgrade grip to the latest available release.

This would also make it possible to include the "execute command after encode
has een completed" patch that can be found from the SourceForge tracker:

<http://sourceforge.net/tracker/index.php?func=detail&aid=1155884&group_id=3714&atid=303714>

This will enable user to configure grip to run "vorbisgain -a" after the
encoding of the album is completed.
Comment 1 Adrian Reber 2008-08-05 12:49:56 EDT
The problem with grip 3.3.1 is that it is marked as a development version and it (used to) has that annoying warning box when started that it should not be used because it is a development version. So I will not update it to 3.3.1.
Comment 2 Stefan Becker 2008-08-05 14:46:41 EDT
OK, I didn't know that.

Can you at least consider to backport that "execute command after encode has been completed" patch? That would be a very useful addition ontop of 3.2.0.
Comment 3 Adrian Reber 2008-08-09 09:58:18 EDT
I will look at applying the patch you mentioned.
Comment 4 Adrian Reber 2008-08-10 11:21:07 EDT
Patch seems to apply. Can you do some tests if it works like it should if I submit it to Fedora 9 updates-testing?
Comment 5 Stefan Becker 2008-08-10 12:33:17 EDT
Sure, go ahead.
Comment 6 Fedora Update System 2008-08-10 14:32:30 EDT
grip-3.2.0-21.fc9 has been submitted as an update for Fedora 9
Comment 7 Stefan Becker 2008-08-11 04:18:45 EDT
Tested with

 external command: /usr/bin/vorbisgain
 external command options: -a -f -n -s /home/stefanb/ogg/%!A/%!d

(the !'s are necessary to force file name munging)

While it seems to work OK the patch is bogus:

 - "execute after encode" works exactly like "encode filter command", which is *NOT* what is desired

 - the implementation is broken as no waitpid() is called to reap dead child processes, i.e. for each encoded track there will be a zombie process :-(

I'll look into the patch to see what can be done...
Comment 8 Stefan Becker 2008-08-11 05:22:13 EDT
Created attachment 313917 [details]
Corrected "execute command after encode" patch

- command is now executed after last encode finnishes
- use the correct launch function to ensure proper cleanup of child processes

Tested with:

 Execute after encode command: /usr/bin/vorbisgain -a -f -n -s /home/stefanb/ogg/%!A/%!d
Comment 9 Fedora Update System 2008-08-12 14:26:30 EDT
grip-3.2.0-21.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update grip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7224
Comment 10 Fedora Update System 2008-08-24 18:28:59 EDT
grip-3.2.0-22.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/grip-3.2.0-22.fc9
Comment 11 Fedora Update System 2008-09-10 02:54:55 EDT
grip-3.2.0-22.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update grip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7703
Comment 12 Fedora Update System 2008-09-24 20:12:43 EDT
grip-3.2.0-22.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.