Bug 457222 - Updating the kernel will need updating firmware packages
Updating the kernel will need updating firmware packages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 08:09 EDT by Hedayat Vatankhah
Modified: 2008-09-13 21:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-13 21:24:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedayat Vatankhah 2008-07-30 08:09:33 EDT
Description of problem:
Recently I've installed Fedora 9 on a system and then updated its kernel to the
latest available kernel. After updating, my wireless card stopped working. It
was because of a missing firmware file. When I updated my firmware package
(iwl4965-firmware), the problem fixed. I think updating the kernel should update
this package automatically.

How reproducible:
Always


Steps to Reproduce:
1. Install Fedora 9 on a system which needs iwl4965 driver
2. Update the kernel using yum
  
Actual results:
Wireless doesn't work anymore and it complains about a missing firmware file
(/lib/firmware/iwlwifi-4965-2.ucode). The problem will be fixed after updating
iwl4965-firmware

Expected results:
Updating the kernel should automatically update iwl4965-firmware package as a
dependency and wireless should work after the kernel update.
Comment 1 Chuck Ebbert 2008-07-30 23:43:13 EDT
I guess we need to add a conflicts: entry for that...
Comment 2 Chuck Ebbert 2008-08-05 00:56:43 EDT
Added conflict against older firmware in kernel-2.6.25.14-107

Note You need to log in before you can comment on or make changes to this bug.