Bug 457244 - setfacl does not recognize -v and -h
setfacl does not recognize -v and -h
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: acl (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 10:17 EDT by Milos Malik
Modified: 2015-02-01 17:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-04 04:21:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2008-07-30 10:17:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.16) Gecko/20080715 Fedora/2.0.0.16-1.fc8 Firefox/2.0.0.16

Description of problem:
In the setfacl source file you can see following code:

struct option long_options[] = {
        ...        
        { "version",            0, 0, 'v' },
        { "help",               0, 0, 'h' },
        { NULL,                 0, 0, 0   },
};

but options "-v" and "-h" are not recognized when you run the setfacl utility. That's because the two options are not mentioned in the following definitions, which are also present in the setfacl source file.

#if !POSIXLY_CORRECT
#define CMD_LINE_OPTIONS "-:bkndm:M:x:X:RLP"
#define CMD_LINE_SPEC "[-bkndRLP] { -m|-M|-x|-X ... } file ..."
#endif
#define POSIXLY_CMD_LINE_OPTIONS "-:bkndm:M:x:X:"
#define POSIXLY_CMD_LINE_SPEC "[-bknd] {-m|-M|-x|-X ... } file ..."


Version-Release number of selected component (if applicable):
acl-2.2.39-13.fc8

How reproducible:
Always


Steps to Reproduce:
$ setfacl -v
setfacl: invalid option -- v
Usage: setfacl [-bkndRLP] { -m|-M|-x|-X ... } file ...
Try `setfacl --help' for more information.
$ setfacl -h
setfacl: invalid option -- h
Usage: setfacl [-bkndRLP] { -m|-M|-x|-X ... } file ...
Try `setfacl --help' for more information.


Actual Results:
'setfacl -v' prints an "invalid option" message
'setfacl -h' prints an "invalid option" message

Expected Results:
'setfacl -v' prints the same message as 'setfacl --version'
'setfacl -h' prints the same message as 'setfacl --help'

Additional info:
Comment 1 Milos Malik 2008-07-30 12:22:43 EDT
What made me to report this bug is the fact that the getfacl utility which comes
from the same package recognizes all 4 options: -v --version -h --help.
Comment 2 Fedora Update System 2008-08-04 04:40:49 EDT
acl-2.2.47-2.fc9 has been submitted as an update for Fedora 9
Comment 3 Fedora Update System 2008-08-04 08:43:11 EDT
acl-2.2.39-14.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-08-07 19:48:15 EDT
acl-2.2.47-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2008-08-07 19:55:02 EDT
acl-2.2.39-14.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.