Bug 457262 - rhn-satellite-export fails with Error: OverflowError caught!
rhn-satellite-export fails with Error: OverflowError caught!
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Pradeep Kilambi
Steve Salevan
:
Depends On:
Blocks: 429319
  Show dependency treegraph
 
Reported: 2008-07-30 11:45 EDT by Patrick Connelly
Modified: 2010-10-22 23:17 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat511
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 15:04:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Connelly 2008-07-30 11:45:03 EDT
Description of problem:
When running rhn-satellite-export against a large channel with the
--make-iso=dvd option, it fails with "Error: OverflowError caught!"

Version-Release number of selected component (if applicable):
rhns-satellite-tools-5.1.0-57


How reproducible:
Always

Steps to Reproduce:
1. Sync the rhel-x86_64-server-5 channel
2. Run /usr/bin/rhn-satellite-exporter -crhel-x86_64-server-5
--dir=/var/satellite/dump --make-isos=dvd
3. Wait
  
Actual results:
isos are created but program dies with error

Expected results:
Exits cleanly

Additional info:
This is a bug in the /usr/share/rhn/satellite_tools/intersat_sync/iss.py file.
Line 1096 reads:

if self.options.make_isos != "dvds":

And should read

if self.options.make_isos != "dvd":

Because the option being passed in is 'dvd' not 'dvds'

Personally, I think this is more of a band-aid for the bigger picture of why the
md5sum is failing for the dvd isos.  Maybe this should be rewritten to not fail.
Comment 4 Jeff Browning 2008-07-31 17:12:32 EDT
Verified. Two ISOs created from the RHEL5 i386 server channel. No errors.
Comment 5 Steve Salevan 2008-08-04 12:13:01 EDT
Moving to RELEASE_PENDING.
Comment 6 Brandon Perkins 2008-08-13 15:04:49 EDT
5.1.1 Satellite is now GA, bugs Closed for Current Release.
Comment 7 Brandon Perkins 2008-08-13 15:09:46 EDT
5.1.1 Satellite is now GA, bugs Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.