This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 457301 - parted: Shows warning message, however partition is created
parted: Shows warning message, however partition is created
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: parted (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Joel Andres Granados
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 15:20 EDT by Shane Bradley
Modified: 2010-10-22 23:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 07:40:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane Bradley 2008-07-30 15:20:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1

Description of problem:
Customer would like to have this this warning message suppressed because they are able to create a partition correctly.

Warning: You requested a partition from 25374988800B to 30000000000B.
The closest location we can manage is 25375021056B to 29997595648B.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
# parted -s /dev/sdb unit B print

Model: SEAGATE ST3146855SS (scsi)
Disk /dev/sdb: 146815737855B
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start         End           Size          Type      File system 
Flags
1      32256B        205631999B    205599744B    primary   ext3        
boot
2      205632000B    21180095999B  20974464000B  primary   ext3
3      21180096000B  25374988799B  4194892800B   primary   linux-swap
4      25374988800B  50000000511B  24625011712B  extended              
lba

# parted -s /dev/sdb unit B mkpart logical 25374988801B 30000000000B
Warning: You requested a partition from 25374988800B to 30000000000B.
The closest location we can manage is 25375021056B to 29997595648B.
--------


Actual Results:
A warning is displayed and partition is created correctly.

Expected Results:
No warning message and partition created.

Additional info:
This was new issue resolved with fix in this bz below:
https://bugzilla.redhat.com/show_bug.cgi?id=441244

Engineer requested a new bz be created on warning message.
Comment 1 Joel Andres Granados 2008-07-31 04:43:38 EDT
The partition was created but I can bet that the start and end are not what the
user put in.  I see your creating the first *logical* partition. And this
partition cannot be created where the *extended* partition begins.  The warning
is there to tell the user the the partition he created will not start or end in
the exact place he intended.
Moreover this is warning is necessary to inform the user of what is happening. 
Imagine specifying 25374988800B and parted silently changing that.  I, as a
user, would be very angry.
If you are using parted as part of a script and don't want to see the output.
then modify your start end so something sane or pipe everything to /dev/null.

Is there something I missed here?

Note You need to log in before you can comment on or make changes to this bug.