Bug 457320 - ATI Rage II cards (mach64) hangs or crashes whole system
ATI Rage II cards (mach64) hangs or crashes whole system
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 17:25 EDT by Samo Dadela
Modified: 2009-07-14 13:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:32:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.80 KB, text/plain)
2008-07-30 20:50 EDT, Samo Dadela
no flags Details
Xorg.0.log of xorg.conf (32.24 KB, text/plain)
2008-07-30 20:51 EDT, Samo Dadela
no flags Details
Xorg.0.log without any xorg.conf (34.96 KB, text/plain)
2008-07-30 20:51 EDT, Samo Dadela
no flags Details

  None (edit)
Description Samo Dadela 2008-07-30 17:25:44 EDT
Description of problem:
ATI Rage II (mach64) crashes X after some time

Version-Release number of selected component (if applicable):
Fedora 9 (freshly installed), Fedora 9 (yum upadte on 30 July 2008, 
xorg-x11-drv-ati-6.8.0-14.fc9.i386)

How reproducible:

Install a:
- ATI Technologies Inc 3D Rage I/II 215GT [Mach64 GT] (rev 41) (prog-if 00 [VGA
controller])

.. I have two versions: one with 4M, one with 2M - both show exactly the same
problems. 

Make some load under X (mplayer, script to run/kill some X programs,
glxgears)... after some time X will crash - freezing the system or rebooting it. 

Tried to replace the graphic card with a PCI Matrox MGA - works. 
Tried to replace the graphic card with a AGP ATI Rage XL - works. 

At first I was concerned because the OS/BIOS chose the same interrupt for the
video card and also ethernet and audio... I than managed to arange the cards in
a order where the video card gets its own IRQ (not shared with other devices). 

Steps to Reproduce:
1. get a ATI Rage II card and install it
2. startx (boot up)
3. make some load (glxgears, mplayer, run/stop X apps)
  
Actual results:
the machine will crash after some time

Expected results:
machine should not crash ;)

Additional info:
the Rage II is set so that it gets its own IRQ (there's a pin on the card to
enable/disable)... crashes in both cases. 
in xorg.conf I tried driver "mach64" (X -configure selects it) and "ati"... in
both cases the result is the same? are those drivers one and the same? 
the card I'm testing has 4Mb of RAM of which 2M is used (16 bit mode "1152x864"). 
windows works perfectly... 

not sure... but once I stopped X and was doing something on the console and the
machine freezed - though that time the card was still sharing interrupts with
eth and audio... so maybe its not xorg ati drivers's fault but the kernel
support for those ATI Rage II cards?
Comment 1 Matěj Cepl 2008-07-30 17:50:19 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Samo Dadela 2008-07-30 20:50:23 EDT
Created attachment 313058 [details]
xorg.conf
Comment 3 Samo Dadela 2008-07-30 20:51:26 EDT
Created attachment 313059 [details]
Xorg.0.log of xorg.conf
Comment 4 Samo Dadela 2008-07-30 20:51:54 EDT
Created attachment 313060 [details]
Xorg.0.log without any xorg.conf
Comment 5 Samo Dadela 2008-08-02 08:31:01 EDT
BTW: I also tested one AGP ATI Rage II C - no problems there... I don't know if
the code for Rage II and Rage II C is the same, but I'm experiencing problems
only on PCI Rage II cards. 
Comment 6 François Cami 2009-02-20 19:13:20 EST
Samo,

Does this happen on F10 as well ?
Could you test with the vesa driver in xorg.conf ?

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Matěj Cepl 2009-05-18 07:53:19 EDT
Reporter, could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 8 Samo Dadela 2009-05-21 03:11:49 EDT
Close it - don't have the hardware to test it anymore, sorry.
Comment 9 Bug Zapper 2009-06-09 22:18:30 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-07-14 13:32:46 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.