Bug 457358 - Hyperlink to Bodhi?
Hyperlink to Bodhi?
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-31 01:47 EDT by Matěj Cepl
Modified: 2018-04-11 03:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-05 05:38:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
git master (73.55 KB, image/png)
2008-07-31 05:56 EDT, Richard Hughes
no flags Details
does what it says on the tin (1.24 KB, patch)
2008-07-31 06:06 EDT, Richard Hughes
no flags Details | Diff

  None (edit)
Description Matěj Cepl 2008-07-31 01:47:19 EDT
Description of problem:
I love the fact that we have hyperlinks to the particular bugs in the Review
Updates List window (well, in the details for the particular package update),
but it would be even better to have also a hyperlink to the Bodhi for the
particular update. So, that in the (unlikely, of course) event something goes
wrong, there would be easy way how to comment in Bodhi.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.2.3-4.fc9.i386
Comment 1 Richard Hughes 2008-07-31 05:56:30 EDT
Created attachment 313084 [details]
git master

What about something like this -- how is the wording?
Comment 2 Richard Hughes 2008-07-31 06:06:57 EDT
Created attachment 313085 [details]
does what it says on the tin

I've applied this to git master -- want me to build an F9 package with this?
Comment 3 Matěj Cepl 2008-07-31 09:27:45 EDT
(In reply to comment #1)
> What about something like this -- how is the wording?

"Vendor" sounds absolutely terrible to me -- don't know what should be better
but something between "Errata" and "Comments"?
Comment 4 Richard Hughes 2008-07-31 12:57:28 EDT
What about Distribution?
Comment 5 Matěj Cepl 2008-08-01 07:59:18 EDT
What does "Distribution" mean for the user? Shouldn't she expect something like
"Fedora", "Debian", there? I guess some action would be better.
Comment 6 Richard Hughes 2008-08-18 04:39:41 EDT
Well I think the user knows what distribution they are using. This feature works great in 0.3.0, so I'll close this and I'll update rawhide today.
Comment 7 Joshua Roys 2009-08-04 16:13:47 EDT
This links to the incorrect update.  For instance, I am presently updating neon to neon-0.28.5-1.fc11 (x86_64).  At the bottom, it says:

For more information about this update please visit this website:
• https://admin.fedoraproject.org/updates/FEDORA-2009-7680.
For more information about bugs fixed by this update please visit this website:
• https://bugzilla.redhat.com/show_bug.cgi?id=491839.

The link to bodhi, however, links to:
pidgin-2.5.8-2.fc11 bugfix update

The correct link has a F11 in it:
https://admin.fedoraproject.org/updates/F11/FEDORA-2009-7680

Still present in current git:
http://cgit.freedesktop.org/packagekit/tree/backends/yum/yumBackend.py#n2323
Comment 8 Joshua Roys 2009-08-04 16:18:10 EDT
It looks like the following works, and might be easier:
https://admin.fedoraproject.org/updates/neon-0.28.5-1.fc11
Comment 9 Richard Hughes 2009-08-05 05:29:43 EDT
(In reply to comment #7)
> The link to bodhi, however, links to:
> pidgin-2.5.8-2.fc11 bugfix update

Urgh. You mean the FEDORA-xxxx-xxxx numbers are the same for packages across releases. Yuk.

> The correct link has a F11 in it:
> https://admin.fedoraproject.org/updates/F11/FEDORA-2009-7680

Okay, cool, we can add that.

(In reply to comment #8)
> It looks like the following works, and might be easier:
> https://admin.fedoraproject.org/updates/neon-0.28.5-1.fc11  

I think that will only work for the basepackage, rather than subpackages, so https://admin.fedoraproject.org/updates/neon-data-0.28.5-1.fc11 (a fictional subpackage of neon) shouldn't exists. I think we just need to extract the "F11" from yum and use that.

Richard.
Comment 10 Richard Hughes 2009-08-05 05:38:44 EDT
commit 250545a41eca1e17e8d5c66fbb86d343151754c6
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Aug 5 10:34:56 2009 +0100

    yum: Include the releasever in the updates link. Fixes rh#457358

Note You need to log in before you can comment on or make changes to this bug.