Bug 457365 - Use Czech instead of English
Use Czech instead of English
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-31 03:42 EDT by Marcela Mašláňová
Modified: 2008-08-01 05:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 05:55:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2008-07-31 03:42:14 EDT
Description of problem:
Some application use Czech instead of US English.

Version-Release number of selected component (if applicable):
kde-l10n-4.1.0-2.fc9

How reproducible:
Set as a first language US English, as a second Czech. Apply changes. There
should be used English everywhere - menus etc.

Steps to Reproduce:
1. run konsole
2. su -
3. there is heslo instead of password, also mc is in Czech for non-root user.
  
Actual results:
Mix of Czech and English in different programmes

Expected results:
Use only English.

Additional info:
I try to restart some programmes and for me are in Czech virt-manager, xchat,
konsole. Thunderbird, konqueror, firefox,... are using proper English localization.
Comment 1 Kevin Kofler 2008-07-31 13:43:22 EDT
Whatever package this is caused by, kde-l10n can't really be it. Reassigning to 
kdelibs for now.

All the affected programs are non-KDE programs (in the case of Konsole, 
the "su -" process running inside it is non-KDE, and that's what's showing the 
password prompt), so it looks like somehow LANG isn't set correctly. Maybe KDE 
4.1 is setting LANG incorrectly? Is this a new issue with 4.1, i.e. are you 
sure this worked in 4.0.x? I couldn't find a change which may be causing this 
while browsing KDE SVN.
Comment 2 Marcela Mašláňová 2008-08-01 02:49:13 EDT
I had this problem before in KDE4.0, but in less application. Maybe the
localization team make more work in last months.
Comment 3 Lukáš Tinkl 2008-08-01 05:55:17 EDT
When you make such a language-related change, you get a warning dialog about
settings being applied on next login, this is normal. Some translations cannot
be applied on the fly as they come from .desktop files or other shared catalogs
that are already loaded in memory.

Note You need to log in before you can comment on or make changes to this bug.