Bug 457369 - system-config-bind reports required packages not installed in error
system-config-bind reports required packages not installed in error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-bind (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-31 04:12 EDT by Timothy Davis
Modified: 2008-08-29 07:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-29 07:37:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SCB initialization error message (20.84 KB, image/png)
2008-07-31 04:12 EDT, Timothy Davis
no flags Details

  None (edit)
Description Timothy Davis 2008-07-31 04:12:50 EDT
Description of problem:
system-config-bind reports that bind bind-lib bind-utils is not installed
although it is.

Version-Release number of selected component (if applicable):
system-config-bind-4.0.8-1.fc10.noarch

How reproducible:
Everytime from either the menu or commandline

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
[root@localhost system-config-bind]# rpm -qa bind*
bind-9.5.1-0.2.b1.fc10.i386
bind-libs-9.5.1-0.2.b1.fc10.i386
bind-utils-9.5.1-0.2.b1.fc10.i386
bind-devel-9.5.1-0.2.b1.fc10.i386
[root@localhost system-config-bind]#
Comment 1 Timothy Davis 2008-07-31 04:12:50 EDT
Created attachment 313079 [details]
SCB initialization error message
Comment 2 Jaroslav Reznik 2008-08-19 08:23:18 EDT
This problem is caused by missing dns-keygen in the new rawhide Bind package. But dns-keygen is RH in house made utility and will not be longer supported (not in upstream). Workaround for F10 - dns-keygen will be packaged again with Bind. And we will look for better solution. Maybe dnssec-keygen -a HMAC-MD5 -b 256 -n HOST rndc with stdout output?
Comment 3 Adam Tkac 2008-08-20 03:37:04 EDT
After inspection keys can be generated with dd if=/dev/random bs=32 count=1 | base64. Moving back to system-config-bind
Comment 4 Jaroslav Reznik 2008-08-20 03:43:40 EDT
Thanks!

dd if=/dev/random bs=32 count=1 2>/dev/null | base64

Note You need to log in before you can comment on or make changes to this bug.