Bug 457381 - pdbedit -G doesn't work
pdbedit -G doesn't work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Simo Sorce
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-31 06:35 EDT by Ales Zelinka
Modified: 2009-09-02 07:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:54:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pdbedit manpage fixes (1.52 KB, patch)
2009-05-20 10:37 EDT, Simo Sorce
no flags Details | Diff

  None (edit)
Description Ales Zelinka 2008-07-31 06:35:28 EDT
Description of problem:
pdbedit -u user -G SID doesn't change the group SID

Version-Release number of selected component (if applicable):
samba-common-3.0.28-1.el5_2.1.x86_64

How reproducible:
always

Steps to Reproduce:
1. pdbedit -u sambauser to see the Group SID
2. pdbedit -u sambauser -G new-sid (for example put 512 to the end instead of
the default 513)
3. pdbedit -u sambauser to see if the Group SID has changed
  
Actual results:
Group sid stays the same

Expected results:
changed Group SID
Comment 2 Simo Sorce 2009-05-20 10:29:57 EDT
I think this is a documentation problem.
The manpage mentions a -G option but there is no such option in the pdbedit utility.
This is consistent with samba behaviour though, as the group SID for a user is always determined by the users primary GID.
So if a special Group SID is needed then you need to create a group mapping and change the system user's primary GID.

I will see how easy it is to patch the manpage.
Comment 3 Simo Sorce 2009-05-20 10:37:16 EDT
Created attachment 344816 [details]
Pdbedit manpage fixes

Turns out the manpage was outdated wrt this option, if it ever existed in the code it doesn't anymore, update manpage to reflect reality.
Comment 8 errata-xmlrpc 2009-09-02 07:54:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1416.html

Note You need to log in before you can comment on or make changes to this bug.