Bug 457446 - Very high CPU usage when watching flash videos on internet (with firefox)
Very high CPU usage when watching flash videos on internet (with firefox)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: swfdec (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-31 14:02 EDT by Florent Le Coz
Modified: 2008-07-31 15:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-31 15:51:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florent Le Coz 2008-07-31 14:02:34 EDT
Description of problem:
When watching flash videos on internet or any flash animations (youtube,
dailymotion, or even sphericuniversexp.com introduction), the CPU goes to 100%
used, the animation is very laggy and the sound jumps (or totaly stops)


Version-Release number of selected component (if applicable):
swfdec-0.6.6-1.fc9.x86_64

How reproducible:
Everytime.

Steps to Reproduce:
1. Go to youtube and watch a video
2. Close firefox because it takes 100% of your CPU
  
Actual results:
Lag and 100% CPU usage

Expected results:
Should not lag.

Additional info:
Comment 1 Brian Pepple 2008-07-31 15:51:09 EDT
This is due to the limitations of xv currently.

From the swfdec faq:
"Here's the problem: As you might know, hardware has a dedicated method to
display video, called the video overlay. That is what xv and in turn mplayer and
ffmpeg use. It has the following features: * reserve a rectangular region on the
screen for video display * move a memory rectangular image of YUV video data to
that region and scale it to fit. That's not a lot and works well enough for
video, but not for Flash. Flash allows rendering stuff on top of the video (the
end screen on Youtube for example has the last video image shine through) and it
allows translucent videos and drawing non-rectangular parts of videos. All of
this is not supported by xv, which is why we decided to not go through the pain
to use it. The unfortunate side effect is that currently a lot more horsepower
is required to display a video via Swfdec.

The end goal is to use OpenGL and its video extensions to speed up Flash video.
That should make it as fast as xv for graphic cards that provide these features
(almost all current graphic cards do). But then, there is currently no OpenGL
cairo backend, even though there's constantly talk about doing one."

Note You need to log in before you can comment on or make changes to this bug.