Bug 457455 - SELinux is complaining about Novell GroupWise library
SELinux is complaining about Novell GroupWise library
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.2
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-31 14:18 EDT by George
Modified: 2009-01-20 16:32 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:32:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George 2008-07-31 14:18:18 EDT
Description of problem:

SELinux is preventing groupwise-bin from loading
/opt/novell/groupwise/client/lib/libgwapijni.so.1 which requires text
relocation.

Version-Release number of selected component (if applicable):


How reproducible:

Launch GroupWise 7.03

Steps to Reproduce:
1. Launch GroupWise 7.03
2. Setroubleshoot Pops Up with error
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Walsh 2008-08-01 10:52:31 EDT
chcon -t textrel_shlib_t /opt/novell/groupwise/client/lib/libgwapijni.so.1

Should fix for now.

This should be reported as a bug to Novel, since they are building their library
incorrectly most likely. Add this link to the bug report.

http://people.redhat.com/~drepper/selinux-mem.html

I will update u3 policy with this file context.

Fixed in selinux-policy-2.4.6-143.el5
Comment 2 RHEL Product and Program Management 2008-08-01 11:10:59 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2009-01-20 16:32:18 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0163.html

Note You need to log in before you can comment on or make changes to this bug.