Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 457512 - Hankaku/Zenkaku not recognized
Summary: Hankaku/Zenkaku not recognized
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 465749 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-01 09:17 UTC by Mamoru TASAKA
Modified: 2018-04-11 11:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-08 01:12:31 UTC
Type: ---


Attachments (Terms of Use)
xorg.conf (3.16 KB, text/plain)
2008-08-01 17:37 UTC, Mamoru TASAKA
no flags Details
Xorg.0.log wit xorg.conf attached above (28.36 KB, text/plain)
2008-08-01 17:37 UTC, Mamoru TASAKA
no flags Details
Xorg.0.log without xorg.conf (29.58 KB, text/plain)
2008-08-01 17:38 UTC, Mamoru TASAKA
no flags Details
Xorg.0.log without xorg.conf (again) (12.83 KB, text/plain)
2008-08-12 10:17 UTC, Mamoru TASAKA
no flags Details
Xorg.0.log without xorg.conf (again) (26.97 KB, text/plain)
2008-09-08 10:08 UTC, Mamoru TASAKA
no flags Details

Description Mamoru TASAKA 2008-08-01 09:17:44 UTC
Description of problem:
(On GNOME Japanese environment) with xorg-x11-server-Xorg-1.4.99.906-2.fc10 
Zenkaku/Hankaku key doesn't seem to be recognized and I cannot enable
scim Japanese typing mode.

Putting xorg-x11-server-Xorg back to xorg-x11-server-Xorg-1.4.99.906-1.fc10 seems
good.


Additional info:
If needed, please tell me what is needed.

Comment 1 Matěj Cepl 2008-08-01 14:26:00 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Mamoru TASAKA 2008-08-01 14:44:11 UTC
Under what EVR of xorg-x11-server-Xorg do you need the logs?

Comment 3 Matěj Cepl 2008-08-01 15:35:52 UTC
In the one where you reproduce the problem.

Comment 4 Mamoru TASAKA 2008-08-01 17:37:04 UTC
Created attachment 313213 [details]
xorg.conf

/etc/X11/xorg.conf

Comment 5 Mamoru TASAKA 2008-08-01 17:37:37 UTC
Created attachment 313214 [details]
Xorg.0.log wit xorg.conf attached above

Comment 6 Mamoru TASAKA 2008-08-01 17:38:45 UTC
Created attachment 313215 [details]
Xorg.0.log without xorg.conf

Xorg.0.log without xorg.conf. Hankaku/Zenkaku won't work even on this state.

Comment 7 Warren Togami 2008-08-02 02:18:39 UTC
We might need some help from eng-i18n.

Comment 8 Akira TAGOH 2008-08-04 11:00:02 UTC
Section "ServerFlags"
    Option "AutoAddDevices" "false"
EndSection

Does it help?

Comment 9 Mamoru TASAKA 2008-08-04 12:37:55 UTC
(In reply to comment #8)
> Section "ServerFlags"
>     Option "AutoAddDevices" "false"
> EndSection
> 
> Does it help?

This seems to work (with xorg-x11-server-Xorg-1.4.99.906-3.fc10)
(Without this section Zenkaku/Hankaku does not work)

Comment 10 Mamoru TASAKA 2008-08-12 10:17:44 UTC
Created attachment 314080 [details]
Xorg.0.log without xorg.conf (again)

Still Hankaku/Zenkaku is not recognized when removing xorg.conf
(xorg-x11-server-Xorg-1.4.99.906-5.fc10)

I also found that when xorg.conf removed '\', '_' are also not recognized,
seemingly similar with bug 434669.

Comment 12 Mamoru TASAKA 2008-09-08 10:08:06 UTC
Created attachment 316066 [details]
Xorg.0.log without xorg.conf (again)

Updating info

With xorg.conf removed Zenkaku/Hankaku '\', '_' are still not recognized with

xorg-x11-server-Xorg-1.5.0-1.fc10.i386
xorg-x11-drv-i810-2.4.2-4.fc10.i386

Comment 13 Tony Fu 2008-09-10 03:13:21 UTC
requested by Jens Petersen (#27995)

Comment 14 Mamoru TASAKA 2008-10-07 13:57:29 UTC
Still xorg-x11-server 1.5.1-6.fc10 Zenkaku/Hankaku is not recognized by
default (default means "without xorg.conf").

I am suggeested on the forum like below:
$ setxkbmap -print
$ setxkbmap -rules evdev -model jp106 -layout jp

Then
First one reports:
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+jp+inet(evdev)+jp:2+group(alts_toggle)+ctrl(swapcaps)+shift(breaks_caps)"   };
        xkb_geometry  { include "pc(pc104)"     };
};

Then after second step Zenkaku/Hankaku works. This time
$ setxkbmap -print 
reports:
xkb_keymap {
        xkb_keycodes  { include "evdev(jp106)+aliases(qwerty)"  };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete+japan"        };
        xkb_symbols   { include "pc+jp+inet(evdev)+group(alts_toggle)+ctrl(swapcaps)+shift(breaks_caps)"};
        xkb_geometry  { include "pc(jp106)"     };
};

Comment 15 Peter Hutterer 2008-10-07 22:34:31 UTC
*** Bug 465749 has been marked as a duplicate of this bug. ***

Comment 16 Peter Hutterer 2008-10-08 01:12:31 UTC
Fixed with xorg-x11-drv-evdev-2.0.6-2.fc10

http://koji.fedoraproject.org/koji/taskinfo?taskID=867661

It's a combination of multiple components. evdev forced model to evdev, even if sysconfig/keyboard required jp106. With xkeyboard-config 1.4 there is now a ruleset evdev, so evdev now needs to force rules evdev, not model.

Comment 17 Mamoru TASAKA 2008-10-08 01:37:11 UTC
Yes, with xorg-x11-drv-evdev-2.0.6-2.fc10 Hankaku/Zenkaku is now correctly
recognized without xorg.conf, thanks!

[tasaka1@localhost ~]$ rpm -q xorg-x11-drv-evdev
xorg-x11-drv-evdev-2.0.6-2.fc10.i386
[tasaka1@localhost ~]$ setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "evdev(jp106)+aliases(qwerty)"  };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+jp+jp:2+inet(evdev)+group(alts_toggle)+ctrl(swapcaps)+shift(breaks_caps)"   };
        xkb_geometry  { include "pc(jp106)"     };
};


Note You need to log in before you can comment on or make changes to this bug.