Bug 457533 - named crashes on incorrect usage of rndc reload command
Summary: named crashes on incorrect usage of rndc reload command
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bind
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Adam Tkac
QA Contact:
URL:
Whiteboard:
: 489662 (view as bug list)
Depends On:
Blocks: 483552
TreeView+ depends on / blocked
 
Reported: 2008-08-01 11:56 UTC by Leon brouwers
Modified: 2014-11-21 17:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 483552 515843 520596 (view as bug list)
Environment:
Last Closed: 2009-01-20 22:16:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0246 0 normal SHIPPED_LIVE bind bug fix update 2009-01-20 16:06:48 UTC

Description Leon brouwers 2008-08-01 11:56:16 UTC
Description of problem:
named crashes (process terminates) on incorrect usage of the rndc reload 
command


Version-Release number of selected component (if applicable):
bind-utils-9.3.4-6.0.2.P1.el5_2.x86_64
bind-9.3.4-6.0.2.P1.el5_2.x86_64
bind-libs-9.3.4-6.0.2.P1.el5_2.x86_64

How reproducible:
every time

Steps to Reproduce:
Server A is the master of a dom.tld zone
Server B is a slave of the dom.tld zone

On server B type: rndc reload hostname.dom.tld
(the correct syntax would have been: rndc reload dom.tld)

The commandline now gives:
[root@yyyy ~]# rndc reload hostname.dom.tld
rndc: connection to remote host closed
This may indicate that the remote server is using an older version of 
the command protocol, this host is not authorized to connect,
or the key is invalid.

The /var/log/messages log gives the following messages:
Aug  1 13:44:01 infiltrator named[8108]: view.c:1135: INSIST(result == 0 || 
result == 23) failed
Aug  1 13:44:01 infiltrator named[8108]: exiting (due to assertion failure)

After this the named process terminates.
 
Expected results:
Error messages from RNDC but no crashes of named

Comment 1 Adam Tkac 2008-08-04 16:01:01 UTC
Right you are, thanks for report.

Comment 5 Jonathan Sulman 2008-12-05 16:24:37 UTC
I have verified this bug on Red Hat Enterprise Linux ES release 4 (Nahant Update 7), running bind-9.2.4-30.el4.

Comment 6 Adam Tkac 2008-12-08 12:02:59 UTC
(In reply to comment #5)
> I have verified this bug on Red Hat Enterprise Linux ES release 4 (Nahant
> Update 7), running bind-9.2.4-30.el4.

Right you are. If you are interested in RHEL4 fix please clone this bug for RHEL4 ("Clone This Bug" in top right corner of this page)

Comment 8 errata-xmlrpc 2009-01-20 22:16:39 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0246.html

Comment 9 Adam Tkac 2009-03-11 10:25:23 UTC
*** Bug 489662 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.